I’m currently building a networking game and I came up with some weird naming.
Why is the playerstate of unreal called “PlayerState”, I mean why not playerinfo or playerstatistics because it holds the score etc of the player.
A playerstate to me is more like this:
The player is now in the “Idle state” or the player is now in the “Moving state”, it’s also handy for building up a statemachine for the player.
And yes I could rename it inside the .ini file but that will only confuse me more …
Then I call the “PlayerState variable” and cast it to a playerinfo or playerstatistic.
And when I’m using a state machine I also get the “Playerstate variable” but this time I cast it to IdlePlayerState or MovePlayerstate …
Isn’t there another solution so I can make this less confusing?