PlayerCharacter Invalidated when running in editor

I have a pretty standard setup in my Main level, where I store a reference to the player character on Event BeginPlay.

Most of the time, my game runs perfectly fine and this reference is used without issue. However, intermittently, when I run the game in the editor (this has never happened when I run it standalone) the PlayerCharacter becomes invalidated a few frames after the reference is set.

When this happens, and I debug the blueprint, you can see that any functions called on the reference simply fail. I’ve attempted to replace the reference usage with calls to GetPlayerCharacter, but in this state that function returns “None” as well. I know, however, that the Character does exist for at least 5 or 6 frames before this happens (I can see one of it’s values being set and displayed on my UI hud before the bug occurs).

Eventually this problem goes away when I’m debugging (can be minutes, hours, or days…will persist through resetting and rebuilding), but it always comes back later.

I’m stumped. Any thoughts on what would cause this to happen so intermittently, and only when running in the editor?