Download

Player sticking on stair steps

I made a blueprint to make stairs using a static mesh for each tread. The script works nicely, but the player is unable to go up the stairs without jumping. The rise on each step is pretty small, so I don’t know why the player is getting hung. I’m tempted to turn off the physics for the steps and just place an invisible ramp under the stairs. Is there a setting to make this work without having to use an invisible ramp or is a ramp the way to go?

You can increase the step height for the player in your character BP. It’s under Defaults tab > Character Movement > Max Step Height.

Hmmm. Step height is set to the default 45, and the steps are only 20 high. It should be working. ???

What’s the Perch radius threshold set to? It’s possible that the game intends to let you step up but the stairs are too short to allow that; if the capsule can only step up outside the perch radius threshhold it uses a separate value for Step Height (I forget what it’s called, it’s like Additional Perch Step Height or something like that) and if that’s set below the stair height that could be causing your issues…

I am not familiar with the perch radius setting. Currently, the stair steps are 30 deep with a rise of 20 units between steps. I did try setting the char step height to 90 with no improvement.

Could you probably post a screenshot of your stairs with collision + which character template do you use?:slight_smile:

I’ll try to get a screenshot, but screenshots on Linux aren’t working. (Invalid headers.) I’m just using the sample MyChar blueprint and the Hero mesh that comes with the templates (Blueprint FPS).

I looked at the collision boxes around the steps. There’s nothing special about them. Just boxes.

-you said that your are using a blueprint for the stairs? -> have you already tried to just place them as static meshes?
-have you made the collision in the bp or inside the static meshe editor?
-have you changed anything at the character bp? :slight_smile:

  1. No, I haven’t tried to make the stairs as a pile of static meshes. Presently, each step is a simple box static mesh that gets spawned and placed using the BP.

  2. The collision box for each step is the one UE4 created for the mesh. It too is a simple box. I didn’t mess with it.

  3. Other than trying to raise the step height to 90, the character BP is unmodified.

I’ll try to make just a pile of steps without using the BP to see what happens. Right now, I’m working on an unrelated bug in the editor, so I need to wait for the compile to finish.

I have the same problem, I have a kerb, 20 high and 20 deep that the character in game (using the FPS template) refuses to walk up.

Here is a shot in Maya of the dimensions

If I change the walkable floor angle to 90 degrees in the character Blueprint it works fine. I’ve tried extending the depth of the kerb to 30 and its still the same. I would like to keep the default settings on the character if at all possible.

The strange thing is, I can walk up a height of 40 units, but not up 20 (as shown below)

Its driving me insane, so any help is appreciated.

Grant

Have you set the export scale to cm? Otherwise it will be larger :slight_smile:

Here’s a screen shot of the collision objects. You have to bunny hop to get up the stairs.

Hmm, really strange… When I recreate your scene I can go up the stairs without jumping. The only thing that could solve the problem temporarly is to increase the step height value to a pretty high value :slight_smile: (increase it step by step).

As I mentioned above check if your steps are really just 20 high :wink:

  • how does the collision look like in the ue4?

Found a fix, but I’m not sure if it’s a proper way to fix the problem.

I went to the Walkable Slope Override tab (under Static Mesh Settings) for the static mesh and set the following:

** Walkable Slope Behavior: Increase Walkable Slope
** Walkable Slope Angle: 90.0

Now the player glides up and down the steps without any problems.

This was super helpful, thank you. Not sure if this is the proper solution either, but you’d think it’d be more obvious.

I had the same problem. In my case the the capsule scale was not set to 1. The character got stuck on 10cm height steps with step height set to 300. Setting the capsule scale back to 1 fixed the problem for me.

I know it’s a super old thread, but I just had the same problem and it was because of auto generated convex collision of the mesh (step). I deleted the collision and created a simple cube based one and it works.