Player start isn't possessing player controller automatically

What the title says. It was working fine at one point the all of a sudden it doesn’t and i have to press f8?

Hi call95,

Have you changed the Game Mode at all? To change it, you could either change it in the World Settings or by going to Edit → Project Settings → Map and Modes → Default Game Mode. Be sure that the Player Controller you’re using is set as the default and it should possess it automatically.

Hope this helps, if not, please feel free to let me know.

Matthew Clark

Have you found the solution to your issue? If you still require assistance, please let me know and I’ll be happy to help.

Hi call95

We haven’t heard from you in a while. In the meantime, I’ll be marking this issue as resolved. Please feel free to comment if you require more assistance and the question will reopen.

i have changed my game mode but still i have to press f8 for the player to start

Ok so it could be either that you are actually starting in simulation mode instead of play in viewport, or you just need to double check you game mode settings.

My guess is that you are simulating which can be changed like so:

134967-choose+play+mode.png

For the game mode, make sure that the game mode is being set in the world settings like so:

134968-specify+game+mode.png

Also that in the game mode blueprint you have set the player pawn and the player controller (if you made a controller and didn’t do all your logic in your pawn):