Download

Player Start In Level

How can I put into my level a first person perspective player?

At the moment when I press play to engage in the level I’m just a floating character but I would like to see from human perspective.

Go to the world properties and choose your gamemode with the fps view :slight_smile:

Is that under World Settings? Or a different tab?

Yep, world settings :smiley:

I think I must be tired, but I can’t seem to find an option to set FPS under the world settings box. I can see gamemode but no option thereafter…

You have to choose **your **gamemode. So the one that you have made → gamemodes are bp’s that you can create. In there you add your player controller, character,…

You have to have an actual character and game mode set up first. Otherwise you are looking at a FPS view (sort of) when you click play it just doesn’t have a character yet.

Yeah I started with just a floaty camera setting not meant for FPS. Just some background of what I’m trying to do. I’m modelling a to-scale house and want to have if possible my height set in game to match my real height. If at all possible.

The easiest way it to choose the fps template (with the blue weapon) - delete the skeletal mesh and the shooting part of the bp - choose the right gamemode in the world settings -> now in the character bp you can change the eye height :slight_smile:

Thanks I finally got the FPS view working now in my map. However how can I lower the perspective? The camera point of view seems much too tall for the scale.

It depends on how you did it ^^ -> when you use a character bp, then you can do that with the eye height in the properties. Or move the camera in the component tab

Can I also reduce the size of the character along with the height? I find it impossible to enter through some doors I’ve made in the map. In real life the doors are fine but for some reason the in game character won’t.

Ah sorry, just tried out the “eye height” and it is not working -> so change the camera height in the component tab (just move it) + there you can also change the size of the character :slight_smile:

Cool. I just reduced the dimensions of the player and a bug seems to happen when below 0.3 value. Very slow movement and drifting in 1 direction. Very odd.

One more thing, how can I set the player to walk instead of run automatically?

Go into the properties tab of your character and set the max walk speed to something lower

Thank you!