Download

Player Start "BAD size" icon

I created 2 different interior archviz scenes and have Player Start “BAD size” icon on both of the scenes now. Both Rooms are wide enough, minimum wall-wall length is more than 3 meters. When I hit the play button, I always start outside of the rooms and can’t get inside. The attachment is one of those. Please help.

In my experience size isn’t the issue. What happened, most likely, is when you imported a model it automatically created a collision mesh of sorts. Since you can’t spawn inside the bounds of any object’s collision it’ll kick you out.

It usually shows this warning when the capsule is too low down on (or under) the ground, try moving it up slightly until the bad size warning goes away.

2 Likes

Hey,
I exported an fbx file from Blender into Unreal Engine 4 and i have same problem with this controller. It says “player start bad size” and gets stuck if i simulate a play. I’ve tryed moving it away from closest objects but it accures that my interior model is being seen as a full block (i can walk on it if the cotroller starts above). I’ve seen an explenation on some forum that i have to defragmentate the model but i don’t really know how since it is defragmentated in Blender . What said #jaredcfw- “it automatically created a collision mesh of sorts” sounds like thats it but i don’t know what does it mean. If you could tell me the way how to resolve this or show me a tut i would be very gratefull. Please note that im new in the subject so if you could explain it like i was retarded it would be also cool.
Greets,
Knyp

You will have to create a proper collision for your mesh -> https://www.youtube.com/watch?v=TTsAYpqHU-c :slight_smile:

After I import my objects from blender into UE4, I double click the asset, go to collision complexity in the details panel and select “use complex collision as simple” This will make a tight collision mesh around your object. I was having the same issue as you because of player start interacting with collision meshes.

As they said probably its involved with the collisions of the meshes. You need the actor to not be colliding with anything in order to not get the error

Select all mesh in content browser, click the right mouse button - Asset Actions - Bulk Edit Via Property Matrix.
In the box that appears press Control + A for all objects you select. You can modify all the selected mesh in “Collision Complexity” section select the drop down the last option “Use Collision As Simple Complex”.

In my case to delete collisions from walls, windows, doors was enought - it always happens when you export few elements and export it into one asset.

1-Make sure the imported mesh has NoCollisions.
tt.PNG

2- Add a BlockingVolume and make the area where the player is going to walk, walls, etc.
ttt.PNG

I am having the same issue. I imported a revit-file in fbx and it looks ok but get the bad actor thingy. So this file has a lot of components, individual walls, tables etc and I have clicked on some and the collision boxes looks fine but again, of the 1000 objects I have no idea if one of them are screwed up. Help?

Changing all meshes to noncollisions is not an option when the imported fbx has 100+ meshes. I tried to do it when importing the file, but there still seems to be a problem. Walking through the imported house seems to be imposible

There seems to be a lot of confusion around collision. So here is a quick guide: you should use two different types of collision depending on the type of mesh you have:

A) pieces of furniture or other (simpler shaped) objects should have simple collision. You can create the simple collision in your modeling software or in unreal. It’s pretty easy to create the collision in unreal. Just look at the Collision menu in the Mesh Browser window. Here I added a 10DOP-Z simple collision and scaled it up a bit so the player won’t be able to step onto the table. You can add multiple collisions here for the same object if necessary and scale or move it like in the normal viewport.

In case you want to create your collision in 3ds max add a second mesh and call it the same as your mesh but with UCX_ in front and a number at the end: UCX_meshname_01 you can add as many of those as you want. The 2nd would be UCX_meshname_02 and so on. Export them together and unreal will discover the collision meshes and add them as simple collision. Btw: leaving a little gap between collisions will save you a tiny bit of memory. And the collision models need to be convex or they won’t work.

collisionsimple.jpg

B) The other type of mesh you have is either very simple like a box that is used as a wall or very complex like a set of walls and floors in a building. In both cases creating a simple collision would be too complex or the same as the mesh itself and there for doesn’t make much sense. You can just use the complex collision (which are the polygons of the mesh) as the player collision. Go the collision settings in the mesh browser (not the top menu, on the right side further down by default) and set the Collision Complexity to “Use Complex Collision As Simple”. That basically means that instead of using a simple collision model the mesh itself is used for collision.

collisioncomplex.jpg

There’s something colliding with the Player Start. Make sure it doesn’t clip with any mesh, especially ones with collision set up.

just turn on “show collisions” in the editor then you can see all the collision round the player start.

same problem here

If you’ve moved it out of the way and it’s still showing bad size, then try deleting it and placing a new one

Sometimes this happens from having auto generate collision selected when importing static mesh assets. (creates very large, strangely oriented collision meshes)

To fix:

-Change your Perspective View Port (Alt+G) in the Editor from Lit to Player Collision and you may likely see one or in some case many over sized collision blocks causing the issue.

-Select the over sized collision block and open up the static mesh editor (Ctrl+E)

-In the static mesh editor select Collision>Simple Collision

-Delete the selected problematic collision block

-Either save and exit the static mesh editor or create new collision (your call)

-Your player character should no longer have a bad size and work accordingly.

Hope that helps!

1 Like

This helped me a lot, thank you!

(also I was mixing/interchanging Navigation and Collisions)