Player start after packed project


i have started a map using the 3rd Person Template, to reuse the gamemode blueprint, and the animation blueprint.

i have created a landscape and some assets, then tried to Compile and build the level.

everything is fine, but when i launch the executable level, the 3rdPersonBlueprint spawns always nowhere.

How Can i edit its default spawn position ?

PS : i am going to replace the epic default mesh/animation with my own, keeping only the AnimationBlurprint and t

please help, i need to fix this because this project had to be submitted to my school by tomorrow

You can place a Player Start node from the top left (by default it’s under commonly used, you should see it, if not search in the tab for Player Start)

If you already have a player start you may need to go into your Project Settings > Maps and Modes and make sure you have the right pawn selected, player controller, etc.

Also, make sure you don’t have a Player Start (say, the default one) stuck in the middle of nowhere and it’s choosing to spawn you in that but failing because of collision, or something.

thank you, but i ve alrady did this, but still nothing, i have also tried what comes here :

again, i am using the 3rd person template, then deleted all the geometry, light, etc… then imported my own assets…
so may be there’s something stuck over there with the 3rd person template ?

this is what i have right now, the player spawn when i hit PLAY on the camera position, but when i compile, it spawn like in the 0,0,0 :

Ah the problem is you have your game mode override set to None (in your World Settings, on the right)

This is forcing it to use NOTHING for your pawn, controller, etc.

Change the game mode override in your world settings to Third Person Game Mode and then it should be OK

If it’s still not OK change the pawn back to Third Person Blueprint Pawn or whatever it’s name is, check that. If that works, but ytour Animation Blueprint doesn’t, the problem is in the pawn.

But fixing your world settings game mode override on the right should fix it

hi again.

sorry but i tried exactly what you have told me… and nothing.

things i ve : ( untouched, the default 3rd person template mode and blueprint )

Player Start

i tried setting up the GameMode to my ThirdPersonGameMode (the default 3rd person template mode and blueprint ), tried also the override gameMode, but still nothing…

problem solved after creating a blank project, and migrating the level
thanks anyway