Download

Player start after packaging

Hi

i have started a map using the 3rd Person Template, to reuse the gamemode blueprint, and the animation blueprint.

i have created a landscape and some assets, then tried to Compile and build the level.

everything is fine, but when i launch the executable level, the 3rdPersonBlueprint spawns always nowhere.

How Can i edit its default spawn position ?

PS : i am going to replace the epic default mesh/animation with my own, keeping only the AnimationBlurprint and the GameMode.

please help, i need to fix this because this project had to be submitted to my school by tomorrow

Place a Player Start in your map where you’d like if you haven’t done so already.

If you do have a Player Start in your level, you may need to check your World Settings (or Project Settings> Maps and Modes) and make sure you have the right default pawn selected.

thank you, but i ve alrady did this, but still nothing, i have also tried what comes here :

https://docs.unrealengine.com/latest/INT/Gameplay/HowTo/SpawnAndDestroyActors/Blueprints/index.html

again, i am using the 3rd person template, then deleted all the geometry, light, etc… then imported my own assets… so may be there’s something stuck over there with the 3rd person template ?

this is what i have right now, the player spawn when i hit PLAY on the camera position, but when i compile, it spawn like in the 0,0,0 :

9fd925a65c6691f1d94089634c5a3343e3de0dcb.jpeg

Ah the problem is you have your game mode override set to None (in your World Settings, on the right)

This is forcing it to use NOTHING for your pawn, controller, etc.

Change the game mode override in your world settings to Third Person Game Mode and then it should be OK

If it’s still not OK change the pawn back to Third Person Blueprint Pawn or whatever it’s name is, check that. If that works, but your AnimationBlueprint doesn’t, the problem is in the pawn.

But fixing your world settings game mode override on the right should fix it

hi again.

sorry but i tried exactly what you have told me… and nothing.

things i ve : ( untouched, the default 3rd person template mode and blueprint )

ThirdPersonBluePrint
ThirdPersonGameMode Player Start

i tried setting up the GameMode to my ThirdPersonGameMode (the default 3rd person template mode and blueprint ), tried also the override gameMode, but still nothing…

problem solved when i created a blanc project, then migrate the level into it