Player spawns at the wrong location and player start allways shows 'bad size'

you should check for errors (compiling) in your player. and make sure that the player dont intersecate anything … surely there are more things to check

As Est_engine said, make sure your PlayerStart actor is not colliding with anything (I suggest move it up way above any surface, then press End to snap it back to the ground)

There are no errors in the player blueprint and the player start is not colliding anything. Ive tried to move the player start around.

Check if the area doesn’t have a big collider around it.

Like if you imported the external walls as one big mesh and you have simple collision assigned to it - it will then span the whole area causing the player to collide wherever you put it.

Ive checked it now. The area has no big collider. Only box brushes. Ive tried to disable the collision of every static mesh too.

That’s strange. Make a new, empty level and start copying the actors one-by-one and see whether it happens again. If so, you should see what caused it

Have you tried changing the value of your characters
‘Spawn Collision Handling Method’ from ‘Try To Adjust Location, Don’t spawn if still collide’ to ‘Always Spawn, Igore Collisions’?

Another idea would be to inspect the ‘ActorBeginOverlap’ Event in your characters event graph blueprint.
It as an ‘Other Actor’ output you could log and see who the other Actor is.
Place a Breakpoint and some logging onto this event.

It’s not working… I’ll delete the level.

In the level click on Show in the Viewport and select Collision. You are getting the Bad Size error because something’s collision is overlapping with the player start. Showing the collision will help you see exactly what it is that it is colliding with it.