Player spawning sometimes at 0,0,0. Desperately need help. I can pay you if you can fix this!

This glitch is really frustrating me as I personally am not able to reproduce it on my machines. I have a 980ti and a 780ti It seems like maybe a bug in Unreal? I just do not know.

I am using Wadstein’s level streaming/loading screen method to stream all the levels in my game: HTF do I? Loading Screens using Level Streaming in Unreal Engine 4 - YouTube

For me, and most of the people who have played my builds this is totally fine. For others, it is not. The biggest example is the following Twitch stream here: [Vinesauce] Vinny - "Alien Afterlife" [BETA] by jeremycouillard (part 1) - YouTube (this user is on a gtx 1080). Sometimes he was able to play the level. Usually, though, he’d appear at 0,0,0 and restart.

You can see right around 9 minutes the level just starts at 0,0,0 without the player spawning. Also, right before that, he started the level and he fell below the level during the loading screen, where I put in a trigger to teleport players back up should this error occur (and then another weird thing - there is a 2nd spawned player where the PlayerStart is…you can see the gun there). But mostly, and what made him quit playing the game, was that the level so often was starting at 0,0,0, didn’t seem to run any of the blueprints, nothing spawns, there’s no controller.

Below are my blueprints, although they are pretty much the same as in that tutorial. I have tried taking out the conditional in the beginning and just giving a manually inputted transform but that didn’t seem to make any difference. Before when I was able to replicate this problem I had a delay in the loading screen level of 2 seconds as he has in the tutorial. When I took this out it never happened again after hours of testing…but then I release a beta of my game and I see it is happening. This is really driving me crazy! I would so appreciate any help! I can also pay money if anyone solves this crazy problem! Here is the beta of the game if anyone could test it? I’m really at a loss what to do here…Alien Afteflife by jeremycouillard
Thank you!

Try changing the Collision Handling Override to ‘Always Spawn’ on the spawn node

The capsule will attempt to spawn in a way that doesn’t collide with anything which can lead to it spawning in a slightly different position. If you turn this off you may get better results.

thanks so much for the replies…I will try changing the collision settings…
but i’m still pretty confused
why does this only happen on some machines?
why would collision problems cause the level to load at 0,0,0 with no controller? the user was not even able to press start to save and quit the game.

Hey Jeremy.

I know this is a pretty old discussion, but I seem to have a very similar problem in my game. Did the ‘Always spawn’ option resolve the issue for you? Did you find another solution?
Hope this message gets to you. I’d really appreciate your insights into the problem.


Hey Kenny,
Yes the always spawn resolved it! Hope that helps you.