Download

Player prevents navmesh area

My AI characters are smokey ghosts that have no collision to the player (“Ignore only pawn”). The player can walk through them. But when the player stands on their way, I think it breaks the nav mesh volume so the AI can’t pass through the player (When I use “AI move to” node).

I want the AI to freely walk through the player since there will be live cutscenes in the game where AI characters walk and talk, and the player will freely walk around the scene, witness the chat from the past of the game.

Any ideas how to make the player not break the nav mesh volume?

To make it more simple, is there any way to make an object not affect the nav mesh bounds volume, when being placed there?

It sounds like your ghost characters have one or more of their components set to affect navigation. Disabling it should allow the AI to path through them as if they weren’t there, provided they also don’t collide with your ghost characters. Note there is such an option on the actor as well as several components so be sure to disable it everywhere.

Thanks for the answer. The components were set to ignore only pawn. Then I set them to ignore every type except world static (for the landscape) so now they can walk through the player.