Player not appearing in Player start

I am making a 2d game sample using this tutorial:
link text

MyCharacter is not appearing in the Player Start. I looked at answers for similar questions and I had set:

In Project Settings->Maps and Modes:

  • Default Game Mode to PaperGameMode,
  • Default Pawn Class in Selected Game Mode to MyCharacter
  • Global Default Server Game Mode to PaperGameMode.

In World Settings I set:

  • Game Mode Override to PaperGameMode
  • Default Pawn Class to MyCharacter

In PaperGameMode Class Defaults Default Pawn Class is MyCharacter.
MyCharacter Blueprint is appearing correctly in Blueprint class editor.
Kill Z in World Settings is set to -1048575.0. Player location Z is 331.

I had set these all settings, but the problem still exists. The Player appears CORRECTLY when I click right mouse button and “Play from here”.
Maybe somebody knows what can be a problem?

It was really strange. My problem disappeared when I went to the next step of the tutorial. I ran game in the “Mobile Preview”. Many things, especially many shaders compiled. And then Player appeared in Player Start.

Christ, I found an answer to my problem by mistake, maybe it gonna work for others. It’s so hidden…

Thank you this resolved my problem as well.