player not affected by world gravity

how do I get the player to be affected by the world gravity?

I forgot to say using blueprinting

Hey @Outworldgame
Any way you could show your blueprint for more feedback?

If you go into the inherited Character Movement, there will be a lot of physics options within your details panel. If you search Gravity, you’ll be able to change the players gravity scale and select if gravity applies while jumping.

Here’s a quick video I found that may also help:

I hope this can fix it, and let me know if there are more issues!

this is what I would normally do but I’m trying to use the world gravity because of the fact that I have a button to flip gravity I’m doing this cus I think this will fix the inverted gravity jumping the problem is that the player isn’t affected by the world gravity but any ways here’s the part of my code I need help with

Sorry, I actually misinterpreted your question a bit! I don’t think you actually need to make a blueprint to accomplish this! If you go into your world settings (on the top nav bar) you’ll see a physics setting. You can then select to enable world gravity and set its scale accordingly.

I hope this can help you out!
-Zen :vulcan_salute:

I did that and the player character just sort of floated around and I had it set to 1 the question is how to get the player to be affected my the gravity

I going to show this link is what’s happening test Unreal Editor 2022 12 09 09 31 46 - YouTube if I start in the air I just go up I even made it negative

ok I fixed the gravity thing and doing this did not do what I thought it was going to so now what I need help with is with the gravity inverted for it to count the roof as a floor