Player collision viewmode doesn't show invisible actors

Reproduction steps:

  • Place a static mesh actor (that has collision geometry) in a level
  • Switch to the player collision viewmode
  • Set the “visible” boolean of the mesh to false
  • The collision geometry will disappear in the viewport
  • Start playing near the actor
  • Notice that the player is still blocked when trying to walk through the actor

Expected result:

As the player collision viewmode is intended to debug collision issues, anything that causes collision is expected to be drawn regardless of the mesh’s visibility.

Versions tested:

  • 4.10.2
  • 4.11 preview 4

Hi Arnage

Unfortunately I have not been able to reproduce this on my end.

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • Are there any other steps I can take to reproduce this?
  • Have you used the “Show Collision” console command to see if the collision is present in the level?
  • Does this only occur in a specific asset or does it occur with any static mesh?

Here’s an example in a new blank project, I only added the cube. It happens with any mesh. Notice how in the rightmost image the player still collides with the cube even though it is not visible in the collision debug view.

I have discovered that this is a known issue and is in our system as OR-3596. Unfortunately, I do not have a timeframe of when this error will be addressed.

Thank you for the reply. In case it is useful, I noticed the following behaviour with the different collision visualization options:

  • Player collision viewmode: as described above
  • Show > Collision toggle in the viewport menu: (Or alt+C) also exhibits the issue described above
  • “Show collision” console command: correctly shows the collision, but also shows the visual mesh, which I would not expect.

I also found out that the experimental RTWidget can also have collision and it will be completely invisible using any of the ‘show collision’ methods.