Player Character not affecting ragdoll simulation

Hello all!

I am working on a project and I have just set up enemy (this alien dog creature) to go in ragdoll when shot.
It is working great, except that player character (green alien in image) is not affecting ragdoll simulation.

When an animated enemy runs on a dead enemy simulation works great, just like player weapon (which is a static mesh created during gameplay).

I created player blueprint from Top-Down template.

I want player capsule to influence ragdoll simulation.
What am I doing wrong?


Hey DanZaidan,

Try setting your CapsuleComponent’s Collision Presets to Custom, and switch No Physics Collision to Collision Enabled. Ragdolls rely on physics, and your Character is set to ignore them currently.

Let me know if that doesn’t fix it for you!

Thanks for your response, .
I did what you told and that didn’t change anything.
However, I was playing with setting and I found a possible solution:
After doing as you said, I changed Object Type from ‘Pawn’ to ‘WorldDynamic’ and it worked!
But are there any drawbacks of changing this setting (because capsule is controlling a pawn)?

1 Like

There may be later on, as anything that is checking for collision against World Dynamic objects will affect your character as well, when you might not want that. A better solution is to check what about your physics objects ( ragdoll dogs) is affecting Pawn object types. It’s possible they are set to Ignore or Overlap Pawns. If you switch that to Block, it should work without having to set your character to a different Object Type.

That worked! mesh component inside character blueprint was set to ‘Ragdoll’ (which ignores pawn collision).

Thank you so much for you time, .