Player 2 Metahuman hair stops following head.

Hello everyone!

(Unreal version 5.0.3)
(Adding all tutorials that I followed, in order, in case they’re needed for any reason!)

I’m making a local-coop game with two characters. They’re both Metahumans, and both have their own meshes.

Both Player 1 and Player 2 are children of the thirdperson_bp, with their own models, both using this tutorial:

3rd Person Character replaced with metahuamn tutorial

I then added the two player aspect, following this tutorial:

Local split screen tutorial

Here’s the problem, Player 2’s hair will stop following their head if they leave the view of Player 1. One idea I have is that it could be due to some in-built prioritization for Player 1’s camera, but I’m not sure how to fix it or to check this.

Here are two videos I took of the issue, in the second one, I switched the character’s around to show that the issue isn’t with the metahuman itself:

Player 2 Hair Glitch
Glitch Example 2 (character’s swapped)

And here are examples of my Player 2 Spawn Code:

I tried both these videos as a solution, but neither worked:

Solution 1
Solution 2

Thank you for reading! Please consider that I’m quite new to Unreal Engine, so beginner language & basic explanations are much appreciated!!

Slight update:

If I have both players on one screen (by turning off ‘split screen’ in the project settings) then both players are able to walk around without hair issues- so this is definitely something to do with spawning in the camera/ split screen, rather than spawning a second player.

Hope this helps!

Its got to do with grooms. They have been bugged (worse than this) since release.

Try looking into any of the groom settings to see if anything makes a difference.

Likely, file yet abother bug report about grooms.

Not sure if it will work with this issue but seeing as it appears to be a binding issue, you could try to manually bind the hair to the character in their blueprints. I saw a post where someone was running into a similar issue when rendering. I know that’s different but maybe the weird offset is something similar. Just in case, I’ll link the post. Maybe it will provide some insight?

About three posts down someone shared how to set it up in the blueprint; here’s his screenshot.

I hope this helps or at the very least helps provide some momentum to a solution!

@WhateverTrevor Hi there, thanks for the response! Although this method didn’t work for my problem, I don’t think there’s a binding issue with the Metahuman itself as the hair appears normal on player 1’s side of the split screen? I think it’s a problem with the camera on player 2’s screen prioritising player 1’s view (although I don’t know for certain, I am quite new to Unreal!)

Last I herd the issue was with binding becase its disabled or enabled at runtime or some similar nonsense.

You could try to see if thats it by manually binding via BP on creation or something similar to that.

1 Like

The binding is all normal (the hair is currently bound to the correct binding element in the player BP) so I’m still not 100% sure what’s causing the issue.

Thanks for your help thought! It might just be an unfortunate bug or something- just a shame is all ^^

This would be a little out of my skill level- but I’m wondering if there would be a way to write manual code/ blueprint to override it and just stick it on his head?

At this point I don’t even mind if the hair loses it’s fluidity or bounce, I just don’t want any of them to be bald anymore lmao :sob:

I tried to import the head into Blender so I could manually attach the hair- but it’s al done in strands and grooms, so it doesn’t seem to be possible.

Any advice/ workarounds are much appreciated, even if they seem like ‘quick fixes’!! ^^

In BP, try to drag the groom onto a blueprint, and from it drag out, type attach, see what options you get.
IF anything comes up, you can probably connect the node up on the begin play event.
IT may be key-typed under Bind / Binding.

Also, it probably will not matter one bit, but parent the groom to the skeletal mesh within the hierarchy. To do that, best way is to add a socket to the head bone (used for hats as well) and just move the groom under the skeletal mesh, then select the socket name in the options for the groom.
Possibly even enable a set master pose component for the groom (not sure that’s possible/if it works, but worth a try).

At a base level, attaching manually to a socket like I said should keep the groom on the head even if the physics are off.
(current screenshot shows it’s paired to “face”, move it up a notch in the body. add the socket to the body. guess that’s not your screenshot. same diff though.)