Play in Editor/Settings Problem - Resolution always changes, cannot set or change defaults

Hello, I am having issues with the Play In Editor settings, as well as the Editor Preferences.

I test my project via Play In Editor Window, since it gives me a good idea of what I am aiming to see. However, no matter what I do, I cannot set any default settings, or if I “can”, it’s never the one thing that matters. When I try to save default settings, I just get this error:

The default configuration file for these settings is not currently writable. Would you like to make it writable?

And no matter what I do from here, those settings never change. The ini file and folder are marked as Read Only in Windows 10, and though the folder is locked as Read Only (I am the admin, no matter what I do, it trips back to Read Only), the Defaulteditor.ini file claims to not be Read Only. The ONLY way to get the resolution to stay at something a sane person would ever use, I have to constantly hammer on “Reset to Default”.

Is there any way to circumvent this? It truly does make HUD design an exercise in madness. I would simply love it if the PIE screen had a designated, set resolution without changing it however it wants to. I cannot see any gameplay or design benefit to a screen resolution that changes at random.

Attached is a screenshot of the error message. Can anyone help me get this sorted out?


The only workaround I found so far that works 100% is running the game as a Standalone Game when testing and pressing Alt+Enter, which will bring the game down to the resolution I am seeking. But still, I want to know if there’s a more immediate resolution to the initial problem I’ve presented here!

I’m afraid the only way to get what you’re after with PIE is to address the read-only permissions issue. You should then be able to update the ini properly and record your desired viewport settings. Have you looked into something like this How to Fix Folder Keeps Reverting to Read Only on Windows 10 - ?

1 Like

Ahh, I was on that exact site earlier! I tried running through every solution posted, and nothing worked. I am guessing I could reinstall Windows and try again, but I won’t be doing that just yet. I’ll have to deal with my tape and glue approach for now I guess : (