Play in Editor not working

I would attach a small video to show what is happening but I can’t, so I’ll try to explain what is happening to the best of my ability.

I have a large world that I am playing around with. When I start at the default level start location (using the FPS blueprint) the PIE (Play in Editor) works. However, when I move the player start location to where I want to actually start, it won’t spawn/play/work. What would cause this?

I am also using World composition wit ha tiled landscape set up. In the past, I would just import a height map as one large landscape but decided against that for resource management. I can’t translate the landscapes in a tiled setup. So I can’t change the location of where the landscape is in the editor (Z position) to get it above the grid, which is usually where I would start the landscape anyways. Does any one know how to move the landscape components in a tiled world?

One more note, I have played with the kill Z settings to no avail.

I hope this image helps as well. The red dot is where I want to start. Red X means it won’t work there.
Blue Check Mark means default starting location and does work but is not where I want to start. You can see the world grid there.

You might need to check which level your player start is associated with. Is it in the Persistent Level or one of your landscape levels? I’ve found putting it in the persistent level is the only way to spawn correctly in world composition since it loads the persistent level, which contains the player spawn, spawns you, then streams in the other levels. If your player spawn is in one of the sub levels, then it would load the persistent level, not be able to find the player start, spawn you at the default location, then load the sub levels, rendering the player start effectively useless.

For your second question about the landscape’s Z position, I think the only way to modify it is when you first create the landscape and can set the location. If you’re already using an imported tiled heightmap set, you could fix it by reimporting and modifying the height before applying (I think), or you could go into landscape sculpt mode, right click the Heightmap layer under Target Layers, and click Export to File. Then create a new landscape at the desired height and go back to the Target Layers and click Import From File to load the old heightmap.

Additionally, the heightmap you’re using could just have some really low values around zero, causing it to go under the grid. This is because the landscapes are designed to be able to be sculpted up and down, so when placed at Z = 0, a flat heightmap level with the grid is actually at the middle, not the bottom. If you really want the very bottom of the landscape to be at Z = 0, your best option is probably finding the distance between Z = 0 and the current bottom of your landscape, then recreate the landscape at Z = whatever the difference is. For example, if the bottom of your heightmap is actually Z = -1000, the difference between 0 and -1000 is 1000, so you’d place the new landscape at Z = 1000.

I hope this helps you!

Looks like the character start is associated with the persistent level. I’m stumped.

I can’t figure out why this just won’t work. :frowning:

So I did a bit of testing and I think I might have the solution. If you have world composition enabled and origin rebasing disabled, having the PlayerStart outside of the technical level bounds will force you to spawn at the default 0,0,0. If you go into World Settings and enable World Origin Rebasing, you can now spawn on PlayerStarts outside the level bounds! You can check if its out of the technical level bounds by going into the grid view mode (the little white icon in the far upper right corner) and seeing if its inside the grid on all three or not. With origin rebasing enabled, however, you don’t need to be inside the grid anymore.

World Origin Rebasing allows you to work with much larger landscapes, letting you have levels larger than the default limit of 20km^2, so it’s basically required if you’re working with a massive landscape. Otherwise you can’t spawn outside of the default bounds, and if you walk out it works similar to the KillZ plane and just kills the actor you’re controlling.

I’m pretty sure this will fix your issue since the screenshot you posted makes the point you want to spawn at look very far away, so it might be outside the default level bounds.

This actually seems to have fixed it. I can’t believe I missed that check box. Stupid expanded settings button always gets me.

So, that fixed the issue with the engine defaulting to 0.0.0 on play. However, that brings up a new issue, which I actually already found a work around for.

If you check World Origin Rebasing BEFORE loading in all of the different landscape tiles, it will actually only load a few of them in what seems to be a random selection. This created an issue where the starting point worked but the landscape my player is supposed to spawn on would fall through it because it didn’t load in. I don’t know if that is by design or a bug.

What needs to be done is I need to load in all of my levels first THEN check World Origin Rebasing. This fixes that issue. It’s not a bid deal… just another thing to work around but it’s functional.

Thank you SOOOOOO much for your help on solving this issue. It really means a lot to me! :smiley:

You’re welcome! I’m glad you got it working. :slight_smile: