Play Anim Montage not Working

Hi, Unreal Engine
Is it normal that (PlayAnimMontage_function) don’t play if it’s called in thirdpersonBp or other BP
well, I’m working on attack system and saw tutorials using playAnimMontage and works fine.
then I tried the process, and it seems not working and I searched about the issue.

And I know that if montage is called from animationBP works fine.
but, that’s not what I want, If leftMouseClick is triggered then playAnimMontage.

If any suggestion about attack system feel free to comment :smiley:

thank you <3

If you can call it in you animation BP then I would suggest creating a custom event node in your enimationBP and maybe call it ‘PlanyAnimMontage’. Then in your characterBP then call the function from your animationBP.

Perhaps you could also use a state machine where then you click the left mouse button, it changes a boolean variable to positive for attack which allows your character to enter the transition to play the animation montage.

I tried the state machine but, it needs to hold left mouse to play,

I want to make it like dragonNest attack system
I actually saw a tutorial just like that, but it seems not working.
in the tutorial playAnimMontage from CharacterBP, it’s working, then I tried nothing happened, I don’t know why :frowning:

Thank for your Answer

There you go…use montageplay

1 Like

myCharacterBP mesh(inherited) is empty coz my 3dModel are by parts, so I need to create skeletal body,arm,foot… So I clear my mesh parts, then I tried to set the mesh(inherited) and follow your process still, nothing happened

I created a new thirdpersonTemplete and tried your process still nothing happened :frowning: this process you gave, is it working on your project? coz if it is working then maybe something wrong with mine :frowning: which I don’t know

Even new project don’t work :frowning:

Thank you for your Answer


I can’t proceed if this problem can’t be resolved :frowning:

I tried 4.14 and 4.10 and still not working, from tutorials I saw they used MontagePlay working, then I tried and still not working :frowning: , so why there’s a function PlayAnimMontage in CharacterBP if you can’t use it?

have you set up an animation blueprint?

This problem is solved.

Thank you for your answer :smiley:


rofl of course totally forgot about that >.<

hope this help

Did it exactly as it is, it isn’t working. Do I have to some stuff in the AnimBP?

whats not working Zizialb?

nvm, i had to add a slot in the animbp

Just wanted to mention for posterity, if you’re using a skeletal mesh that doesn’t have an AnimBP, you can still play a montage, but not using the Play Montage node. You need to use “Play Animation” instead. This will also take a Montage as the animation type to play. Just make sure your mesh is set to “Use Anim Asset” and turn off the “Playing” and “Looping” values which you will obviously control with the Play Animation node. You can also use “Get Play Length” from your montage to see the total length of the montage so that you can correctly trigger events to happen after the montage completes. The nice thing is that if you use an animation (or multiple animations) that’s set to a different play rate than 1.0, it will calculate this correctly with the Get Play Length node provided you don’t change the rate of the montage itself.

If none of that works for you - check the blend time animation for the montage. If it is shorter than your actual animation - reduce it. It helped me to fix shooting montage anim

1 Like

Just wanted to chime in that the Slot thing worked for me.

In my case, I was trying to use existing animations from a UE Marketplace asset I bought (ladder animations), and it had its own slot made for it (they used a default slot for just the climbing, and a separate one for getting on/off the ladder).

I created a slot with the same name as what the ending animation (climbing off the ladder), plugged that into my character’s AnimGraph and it worked!

Maybe another way to go about it is to make a slot just for your animation. Did not test that but maybe worth a try?

if you use “layered blend per bone” check layer setup