Platforms with No Compiled Support for Android

Hi -

I’m running into an issue where I am on UE5 dev, on the main branch for 5.1.0 (same issue with 5.0.0) and I am seeing Android under “Platforms with no compiled support” and it is missing “AutoSDK”. How do I fix this issue? I also can’t see Android under Platforms in the Project Settings.

I’ve run the SetupAndroid.bat and assume I have installed the SDKs, including those from Visual Studio. Not sure what AutoSDK is and search results aren’t helpful.


WARNING: Unable to find a valid SDK for Android. Found Version: r21b. Must be between r21a and r23a

Is it not?

Alright, there’s some weird issue where the env vars are getting set by the builder but they are getting set to the wrong directories. A solution is to set all your SDKs up appropriately and then return true for HasAnySDK in AndroidPlatformSDK. This bug happens when Android studio has a non-default SDK location that is changed or removed.

1 Like

Thanks for your insight, having the exact same issue on Linux. Using your idea of making it return true, in the HasAnySDK was genius – I checked the source code (funny thing is my ndk is exact match for what they wanted based on the code, no idea why it was failing). Even tried installing several versions and pointing to them each manually – it detected each one and even put the version of them but then returned the same error of needing to between r21a - r23a.

However what worked for me was:

According to the source code FORCE_ANDROID_SDK_ENABLED bypasses the broken check…