Platform Android Not Appear !!

Hi :rolleyes:
All configuration steps for android platform i did it carefully like official UE4 document, i installed TADP, ADT, Android SDK and sure Environment Variables everything OK, but when i run UE4 and opened Project settings and under Platforms in left side i didn’t find Android Platform only Windows and iOS appears…

1-- What is my missing step here ?
2-- is necessary connecting my phone to appear Android platform in project settings?

Hello again, I can’t answer (1) but I’ve just tried (2) on my machine and Android still appears in Project Settings when the phone isn’t plugged in. (It doesn’t however appear in the UE4 Launch menu).

Going back to (1) I don’t know what you have missed if anything?. So I would try is:
(1)… Have you installed the Android USB driver? If no, then install that.
(2)… I would (make sure your phone has development enabled) and then try plugging in your phone, before you run Unreal, that way it’ll make sure its detected.
(3)… also before you run Unreal, confirm its running with the Android tools first. You can try (4) to test it without unreal.
(4)… To make sure its detected, Goto C:\NVPACK\android-sdk-windows ools and then run monitor.bat in that directory.
At the bottom of the monitor on the left hand lower corner, there is a LogCat tab, select that and you should see debug messages coming from your phone.

If all of that works, then I don’t know what else to try?

I would say its best to confirm Android tools works (and your phone is in development mode) before you try it with Unreal. That’ll help narrow down what is going on?.

Good luck :slight_smile:

check this answer

Are you trying to launch to device or just get a build created?
Did you set up the environment variables in both system and user lists?
Also - go to project settings and roll down to android. If it has the red bar, make sure to click the “Configure now” button



When I installed TADP the setup only add environment variables in user lists, is it necessary to add them manually to system

I had to put the vars in both lists, yes.

When i build UE4 through VS Pro 2013 i chose WIN64 Build Platform, when build finished and i run the win64 editor i found only two platforms windows and iOS is this means i must build the engine again but this time for Android Platform ?

Very sorry, I can only a little English. Your problem may be because you have not properly installed Microsoft’s directx sdk.You can try:)

Android Appeared in the Editor :smiley:
I fixed the problem by RE-Build the engine again but this time after installing TADP

Thanks for everyone tried help me :rolleyes: