Placement Settings

Okay, I have created a structure to scale and when I try to place it on a foundation it snaps too high and is not meeting the floor (by a lot, about 1/3 of the height up). I am trying to figure out which setting adjusts the z axis to lower it down when placing. I am also having issues with the corners meeting up and not overlapping so any nod in the right direction for placement lining up would be great. I have been searching and have not found a guide on fixing this issue.

There is a button in the viewport that can be used to turn on and off snapping and there is another one to the right of it that lets you set the distance between grid lines that it snaps to.


(I am going to make some assumptions) Assuming the structure is a Blueprinted Structure similar to the ones used in ARK and you have the static mesh in the blueprint along with a Root component just like the ARK Structures. Go into Your Structure Blueprint -> Components TAB -> Select the Static Mesh for your object and in your details Panel Under Transform adjust your Z location. You can do this in the editor while “playing” with the item built so that you can see where it ends up in relation to your other objects. (I hope that helps)