Download

Pixel Streaming + Nvidia Tesla T4

Hello. I have already posted the quesion to https://answers.unrealengine.com/que…8698/view.html, but may be here i get an answer quickly :slight_smile:

I have an issue with running Unreal Engine 4 simple third person game instance.

I have a Google Cloud Windows Server 2019 with Nvidia Tesla T4 GPU with installed driver that i was downloaded from an official site.

The server have DirectX 12, but when i’m trying to launch my simple game, i have an error “DX11 feature level 10.0 is required to run the engine”.

Video driver are istalled correctly and inside DirectX Diagnostic Tool every thing is fine.

In docs i can see that Tesla is the best choise:

If you plan to run multiple instances of the Unreal Engine using Pixel Streaming on the same computer, note that many consumer-level graphics cards such as the NVIDIA GeForce line can only run a maximum of two encoders at the same time. Professional-grade cards such as the Quadro and Tesla do not have the same limitation.

But i don’t know how to run the simple game on it.

Please, help me guys. It’s very important question!

The problem was solved by this server configuration:
https://console.cloud.google.com/marketplace/details/nvidia/nvidia-quadro-vws-win2019?q=nvidia%20quadro%20virtual%20workstation%20-%20windows%20server%202019&id=d5bab29e-57df-4a53-bac2-d3c3d51a7acd&project=charged-camera-237517

We have no rights to access that configuration. Can you give a bit more details on how did you set it up?

My problem that I can’t get T4 to show RTX. Did you get real-time ray tracing working on T4 instance?

I have the same issue with the same hardware and instance as @AntonWhyBIM.com. The link from @KostensSTV is not accessible, “no permission to access the project.”

I’ve tried this link from incognito tab and it’s work:

https://console.cloud.google.com/marketplace/details/nvidia/nvidia-quadro-vws-win2019?q=NVIDIA%20Quadro%20Virtual%20Workstation%20-%20Windows%20Server%202019&id=d5bab29e-57df-4a53-bac2-d3c3d51a7acd

But if it’s not:

  1. open google cloud marketplace: Google Cloud Platform
  2. search the server name: NVIDIA Quadro Virtual Workstation - Windows Server 2019

Hey KostenSTV, thanks for this update. I really appreciate it…

Quick question with Google cloud can you set the pixel streaming to open a new instance for each client?

I haven’t gotten Google cloud working yet, working on that today. Maybe someone else knows.

Did you get ray tracing working?
I’ve been able to run Unreal very stable on google compute engine, but raytracing doesn’t work.
I’m currently testing different driver configurations, but so far unsuccessful

Did anyone get raytracing working. on AWS or GC
I have tested Unreal App with multiple streams and works fine on Amazon g4dn instance. It has Nvidia Tesla T4 . But ray tracing does not work.
Amazon also have “NVIDIA Quadro Virtual Workstation - Windows Server 2019” on its marketplace, I have tried this AMI and ray tracing seems to work, however with single stream CPU reached at 30% and stays there, even with no mouse move or click on browser end. During that session GPU stays less than 3%.
It seems the AMI and drivers utilizes software based encoder rather GPU hardware.
Any thoughts or idea?
I have also tried aws G4ad instance, it has AMD Radeon Pro V520. It does not even load Unreal App. Error I got “AMF not supported with a D3D12 renderer”

If you are using the Nvidia T4 you should install the vGaming drivers to utilize RTX. The default drivers are workstation/desktop and those have no RTX support.