[Pixel Stream] Bitrate drop

Hi everyone!

With my team, we are currently developing an app that should be accessible via Pixel Streaming.

Everything begin to run smoothly, we are working with amazon servers, we can stream our app, we can control it via an html interface and Json requests, we have almost done!


Sometime we face bitrates drop…And as soon as it appears the stream is totally unable to get back to its previous bitrate value. The only way to get this value back is by refreshing the page and by the way restarting the application.

has one of you already faced this kind of issue? Are we missing something?

Thank you in advance!

I’m doing some tests with Pixel Streaming and this happens to me as well.
I’d like to know if somebody who has experienced this, did find a solution.

This happens to me as well.
I’d like to know if somebody who experienced this issue, did find a way to fix it.

Hi, We have the same problem …
running the app from my pc as a server and connecting to it from another pc in my house, I get great latency and great bitrate and the quality is amazing.
but when i deploy it on aws and try to connect from several pc in my country, I experience a drop in bitrate and really choppy pixelized experience…

as I understand it the webRTC protocol should adapt to the changing quality in the global internet and things should go smooth at least with 30 fps and a reasonable resolution (not even HD),
its the same technology as zoom and other webcams and even several online movie companies isn’t it ?

It would really help if someone from epic could help …
maybe supply best practice for settings in the game itself or in the inner webRTC .
thanks !


Same issue here. Anyone found a solution yet?


Sorry for the late late late answer…

We finally managed to deal with stream compression.

There are some commands lines that allows us to change bitrate quality, especially this one : [TABLE]


If you put it to 0, it will completely reset the stream quality to its best! But it will have a huge cost on your bandwidth. To deal with it, we sent the command Encoder.MaxBitrate 0 at specific times and directly after we change it again for another value like Encore.MaxBitrate 5 000 000 (not sure about this one). It will reset the stream quality and then switch to a value that won’t overload your bandwidth.

As our project allow us to do this reset on specific events, it does the trick for us! However that’s still a really strange behaviour, it’s really sad that Epic Games doesn’t go deeper into this technology.

Let me know if it helps :wink:

1 Like

Hi, I have the Unreal Engine 4.25 version and the command Encoder.MaxBitrate doesn’t work.

I have resolved this now the command is:
Found in “UE_4.25\Engine\Plugins\Media\PixelStreaming\Source\PixelStreaming\Private\Codecs\VideoEncoder.cpp”