Download

Pivot points import Incorrectly.

Hi, I have a hotel scene with 60 rooms. I set the pivot points of the doors in 3dsmax so the doors will open with different rotation, then exported in Ue4. Most of the pivot points are now incorrect in Ue4 which means my doors will not open correctly. Please can someone let me know where I’m going wrong. Please see comparison screenshots between 3ds Max and Ue4 below. Basically how do I keep my pivot point locations when exporting from 3ds max into Ue4?

I have tried changing the pivot points in Ue4 using Pivot offset, but when I make a Class Blueprint with the door as a Static mesh, the pivot point is incorrect again?

Before you export to UE4 you need to move the object to 0,0,0 otherwise the pivot will be offset by its location to the origin.

If you want to “fix it” directly in UE4, since you are going anyway to turn the doors into Blueprints, you can use a Scene Component as root component and parent the door mesh to it. Translate the door until the hinges are aligned along the Z with the root scene component. You can then pivot around the root and the door should rotate as expected.

1 Like

Great, thanks for the feedback,much appreciated. I have a much bigger problem now. My scene wont package.

I am trying to ship a game in development mode. I’ve tried deleting saved folders, config, Intermediate. I haven’t renamed or migrated from another version of Ue4.

Please find link to Pastebin and full Log. - Ue4 Build, Log - Pastebin.com

I was meant to hand this in yesterday, any help would be very much appreciated.

I keep getting the same two error messages:

UATHelper: Packaging (Windows (64-bit)): LogMeshUtilities: Error: Raw Mesh data contains no mesh data to build a mesh that can be rendered.
UATHelper: Packaging (Windows (64-bit)): LogStaticMesh: Error: Failed to build static mesh. See previous line(s) for details.

Try to migrate your level (all dependent assets should also be automatically migrated with it) to a new empty project and re-package. There seem to be some spurious dependencies to deleted assets.

No need to say but I will say it anyway: make a full backup copy of your current project before attempting any of the above.

Those errors mean that there’s an object in the scene (a staticmesh actor) and in the mesh slot for the properties of that object there’s no mesh.

Great, thanks for the help, so I need to manually check every static mesh for this, is there no faster way to do it?

Migrating the level should fix this. Theoretically.

I have checked all static meshes, all seems fine. Is there anyway other way to check for this as I’m still getting the same error messages. I’ve migrated project to new blank project, I have deleted Intermediate, Saved folders ( Newbie question, it won’t let me delete the entire Saved folder because I’m using the saved file when I load the scene?).

Does anyone have any other advice, I’m really lost, I know its probably a small issue, but I need to packaged this scene, the client is getting impatient, and I cant lose everything I worked on for the past month because I cant package this scene. Anyone, Please help.

Can you upload the UAT_Log thats in C:\Users*yourpcname*\AppData\Roaming\Unreal Engine\AutomationTool\Logs*yourue4version*

You should be able to delete the Saved folder with the Editor closed, unless for some reasons there are files that became read only or are locked by other applications.

What you can also try is a divide-and-conquer approach: make a copy of your project, open the copy, delete everything from the level, package. Does it work? If no, try to copy/paste the content to a new level. If yes, Undo the delete, now delete only half of the content of the level, package. Does it work? If yes, the problem was in the part you deleted. If not, it is the the other half. Now keep going until you have narrowed it down to the mesh(es) which is creating the trouble with the build.

Usually this is helpful to narrow down where exactly the problem is.

Thanks for the advice, much appreciated. I have 3 levels with this project, so I will have to delete one level at a time, see which level it is first. Then delete sections of the level until I find the culprit. I’ve checked every mesh in every layer and none of them were missing any mesh components. Thanks again for your advice Marco.

Hi NasteX, just dong one final build, then will post my log here.thanks for the advice. I have to get this right, today.

Ok, just failed another build. This is so frustrating. Please find link to the UAT_Log.: UAT_Log - Pastebin.com

Hello Graeme, I just fixed mine, I had a static mesh imported which was completley empty. For me it was called DummyObject which must have been imported by datasmith. Check through your static meshes until you find one with 0 vertices and delete it

Hi Orkney, Ok, Will do. Glad you managed to fix yours. Thanks for the heads up.

Ok all fixed. Thanks to Orkney. I found a DummyMesh object with no vertices. Deleted it. Packaged fine. Thanks For all the help. Very much appreciated.