Download

Pin 'n' has an unexpected type: int64

Latest UE4.

When I compile my blueprint in UE4 Editor, I get the error message
Pin ‘n’ has an unexpected type: int64
I can not find where in the blueprints the error is.

  • The log file just repeats the same error message.
  • I tried looking at every function in the blueprint and none had any red errors. (Unless I missed it somehow)

How do I turn up verbosity in the editor when compiling blueprints?
Or is there some other way to find it.

When I get a compile error in blueprints, it also has underlined links to the place where the error happens. Do you not get these links, to click to go to the location?

Found It! It was a Format Text node, and the input was called {n} and an integer64 was the input. Convert to a hex string and used that.

But BUG?: There was no function name after the error message. It should have been
Pin ‘n’ has an unexpected type: int64 fucntion TeleportToWorld
I can not replicate this in UE 4.26.2-15973114+++UE4+Release-4.26
It may be a leftover node to node link from upgrading from 4.25