Download

PIE with mouse and keyboard?

Is This Possible?

HELLO?

These forums dead like UT4?

guess so…

What do you mean…a pie menu?

hello ? am I saying something wrong ?

Play In Editor

So, when level designing and making thousands of iterations per day, I would like to know if each time a change is made, I would have to put a VR headset on to check the outcome of that which has been designed.

Concerning the modding it is not necessary to put the vr headset each time you are changing something as you can use keyboard and mouse.

Explain - as far as I can tell, to playtest any levels, I have to put the VR headset on.

You can do like this:

​​​​​​​

Thanks, but that was the very first thing I tried to no avail.

Can you please upload a video of you hitting that button and showing me what happens, because when I do it, all I get is a white screen in the editor viewport. No joy.

OK when you have that white screen in the editor viewport you are almost there;)…just move the arrow of the mouse on it and RMB or LMB and you will see a small message about the mouse.
After that:
(For me ) I just push the P key on the keyboard and after few seconds you are in the elevator…:slight_smile:
Enjoy …

Tried that, I just move through all walls and floors - nothing works

They certainly change the inputs with a new update.
Can you try with a Xbox games, perhaps it is a solution.
I don’t know as I’m not making mod now on RR.
or you can in the project setting make change to the default input.ini
see doc UE4 on : Input Action And Axis Mappings In UE4

Sorry - that method does not allow me to do what I want it do for level design - uninstalling…

[USER=“30254”]Mitch Mitchell[/USER] yes, unfortunately this is a VR game and they designed the mod editor around that fact. You can simulate levels in the viewport, but to test out a level you do indeed have to put your headset on… as that’s how you’ll be playing the levels afterwards. Trust me though, it’s not as annoying as it sounds. If my mod levels are any evidence of such, I’ve made a decent amount of them -

Over a year ago - no changes that I can see: VR requires VR to do level design. This is not good. I think this thread has run its course, and should really be considered a necro thread now.

Thanks all.

Fair enough. Yeah, it’s a very old editor, back from when everyone was excited to do development for UE4 in VR, so I think the mod maker kinda pushed that front. I haven’t seen any other ways to test levels in the editor, and I’ve used it for like 2 years. Cheers Mitch!

Hi!

I know it’s an old topic, but maybe somebody is still looking for this. So, Yes, you can test / play your Robo Recall MOD without a VR device.

You just need to hit the button Play (play this level in VR) > Wait for the new window opens (the new window will be white probably) > Using your mouse, click on the new window > Using your keyboard hit “Space bar” > Hit “P” > Wait some seconds, and the game will start probably.

Basic commands in-game:

  • Mouse to look around;
  • Space bar to teleport;
  • “Q” and “E” to get your revolver (you need to look at it first).