PhysX seems causing performance issue for dedicated server

Hello,
Recently I have found our dedicated server often randomly hangs for about 20 seconds. After some investigation, I think it could be something related to phyx. After using “stat dumphitches”, this is what I have got:

>     [2020.09.23-19.03.54:624][939]LogStats: ------------------Thread Hitch 2, Frame 108939  3404.2ms ---------------
>     [2020.09.23-19.03.54:624][939]LogStats: ------------------ Game Thread 3404.19ms
>     [2020.09.23-19.03.54:624][939]LogStats:   3404.171ms (   5)  -  Thread_a3c_0 - GameThread - STATGROUP_Threads -
> STATCAT_Advanced
>     [2020.09.23-19.03.54:624][939]LogStats:     3404.154ms (   2)  -  FrameTime - STAT_FrameTime - STATGROUP_Engine -
> STATCAT_Advanced
>     [2020.09.23-19.03.54:624][939]LogStats:       3404.094ms (   1)  -  GameEngine Tick - STAT_GameEngineTick - STATGROUP_Engine - STATCAT_Advanced
>     [2020.09.23-19.03.54:624][939]LogStats:         3404.074ms (   1)  -  World Tick Time - STAT_WorldTickTime - STATGROUP_Game - STATCAT_Advanced
>     [2020.09.23-19.03.54:624][939]LogStats:           3391.590ms (   6)  -  Tick Time - STAT_TickTime - STATGROUP_Game -
> STATCAT_Advanced
>     [2020.09.23-19.03.54:624][939]LogStats:             3389.674ms (   2)  -  TG_StartPhysics - STAT_TG_StartPhysics - STATGROUP_TickGroups -
> STATCAT_Advanced
>     [2020.09.23-19.03.54:624][939]LogStats:               3389.670ms (   2)  -  ReleaseTickGroup Block - STAT_ReleaseTickGroup_Block -
> STATGROUP_TickGroups -
> STATCAT_Advanced
>     [2020.09.23-19.03.54:624][939]LogStats:                 3389.667ms (   1)  -  Game TaskGraph Tasks - STAT_TaskGraph_GameTasks -
> STATGROUP_Threading - STATCAT_Advanced
>     [2020.09.23-19.03.54:624][939]LogStats:                   3389.238ms (   2)  -  FTickFunctionTask -
> STATGROUP_TaskGraphTasks -
> STATCAT_Advanced
>     [2020.09.23-19.03.54:624][939]LogStats:                     3389.236ms (   1)  -  FStartPhysicsTickFunction_ExecuteTick
> - STATGROUP_Quick - STATCAT_Advanced
>     [2020.09.23-19.03.54:624][939]LogStats:                       3389.094ms (   1)  -  FetchAndStart Time (all) - STAT_TotalPhysicsTime -
> STATGROUP_Physics - STATCAT_Advanced
>     [2020.09.23-19.03.54:624][939]LogStats:                         3389.094ms (   1)  -  Start Physics Time - STAT_PhysicsKickOffDynamicsTime
> - STATGROUP_Physics - STATCAT_Advanced
>     [2020.09.23-19.03.54:624][939]LogStats:                           3389.059ms (   2)  -  PhysX Single Thread Task - STAT_PhysXSingleThread -
> STATGROUP_Physics - STATCAT_Advanced
>     [2020.09.23-19.03.54:624][939]LogStats:                             3382.294ms (  24)  -  PxsContext.contactManagerDiscreteUpdate
> - STATGROUP_PhysXTasks - STATCAT_Advanced
>     [2020.09.23-19.03.54:624][939]LogStats:                               3382.293ms (  24)  -  Self
>     [2020.09.23-19.03.54:624][939]LogStats:                               0.001ms (   2)  -  OtherChildren

Have anybody encountered similar issue before?

Thanks in advance.

Hey. Do you ever found a solution to this?