Physx Crashes in Packaged Build on Actor spawn

I have this nonsense in my crash reporter window


Access violation - code c0000005
(first/second chance not available)

[d:\build++ue4+release-4.16+physx_compile\sync\engine\source\thirdparty\physx\physx_3.4\source\physx\src\npscene.cpp:2234] PhysX3_x64!physx::NpScene::fetchResults()
[d:\build++ue4+release-4.16+physx_compile\sync\engine\source\thirdparty\physx\physx_3.4\source\physx\src\npscene.cpp:2312] APEXFramework_x64!nvidia::apex::ApexScene::fetchResults()
[d:\build++ue4+release-4.16+physx_compile\sync\engine\source\thirdparty\physx\apex_1.4\framework\src\apexscene.cpp:1377] NordicWarriors_Win64_Shipping!FPhysScene::ProcessPhysScene()

I assume that it happens on an Actor spawn - but I am not sure…
May anyone shed some light why it happens ?
and how to work this round ?

It seems like this thing is happening when the spawned actor is overlapping/colliding with in scene Actor which is set to Collision Enabled and generates Overlap events.

Scenario Expand:
When my Character is dying I am setting it’s location to unseen location - and Disabling physics on its components
Then I am spawning it’s dead body (that simulates physics)
Assumption when setting location and disabling physics in the same frame → could potentionally lead to a physx crash ???

Setting time to disable physx or transform on the next thread did not resolve the issue!

The only workaround I found so far is to completely disable the Async Scene in the project settings!!!

Epic please - do you have some better workaround without disabling the Async scene ?
or… actually… I bet I will just let it be disabled - seems like it brings nothing then bad things :frowning:

Well at-least you used SSE instructions for this → good job :-)!