Physis Issues - inconsitent simulation between PIE and standalone

Hi,

We are having some issues with physics in UE4, to rule out anything else causing it within our project I created a small content only project with a simple blueprint that applies a upwards force to a sphere.

39032-physicstestbp.png

Unfortunately it seems it is a bug with the engine and not our project. We get Inconsistent physics simulation between PIE mode and the standalone game, this has been reported by other users [(link)][2].

I have uploaded a video showing the behaviour I’m taking about.
In the video, we show the test running in PIE mode and as standalone game, with smooth frame rate and fixed frame rate and with substepping on/off.

If you compare t=0:00-0:11 (PIE) in the [video][3]
with t=0:40-0:50 (standalone) [link][4]
you can see the difference in simulation with the exact same framerate settings.

So we thought, let’s try fixed frame rate @30, which well, just doesn’t work:
If you compare t=0:12-0:24 (PIE) [(link)][5]
with t=0:51-1:01 (standalone) [(link)][6]
you will also see a drastic difference between the simulations and please note the framerate of approx 100fps not the fixed 30.

We are working on 2 projects that are both heavily dependent upon physics and these issues are making our life hell for playtesting the game. We have been using the latest promoted branch (changelist 2505032) however I ran the same test project using 4.7.5 downloaded through the launcher and the problem is the same.

Hello PBKS,

I was able to reproduce this issue on our end. I have written up a report (UE-13929) and I have sent it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for you time and information.

Make it a great day

The problem is you don’t want to use ‘Add Force’ for instantaneous applications like this, you want to use ‘Add Impulse’ instead. ‘Add Force’ is for applying steady force over long periods, so is scaled by the length of the timestep.

1 Like

Thanks, tried that and it works - what about the fixed frame rate? There is still a massive difference in the simulation between fixed and smooth frame rates, also the fixed frame rate doesnt appear to be fixed as still runs at ~100fps