Download

Physics Problems with Ponytail

Hey everyone,

I’ve been trying use physics for the hair of my character for months, but no matter how I tweak the values, I just can’t get any decent results out of it. It looks ok when I pull and poke the joint chain in the physics editor, but it’s just flailing around wildly in the game. On top of that, the joint chain ignores the collision bodies in-game, but they clearly work in the editor.

I’m using substepping and played around with those values as well. It’s better than without substepping, but definitely not usable.

Is there anything more I can do other than changing the dampening values of the physics bodies or limits of the constrains? I’ve checked the documentation and any tutorials I could find, but there’s no mention of this problem anywhere.

I’m completely out of ideas with this, so any help would be very much appreciated.

same problem. nobdoy ever bothered to answer: Physics Assets Collide with Character Mesh - UE4 AnswerHub
I tried physics assets stuff, jiggle bones stuff, voodoo magic… nothing works.
I guess the only solution is to use apex maybe, but I’m hesitant to try it (never used it, not enough time :frowning: ).

APEX -can- work really well, but it depends on the kind of hairstyle you’re aiming for and it comes with quite a few technical constrains. For example the ponytail would have to be one connected mesh and it doesn’t support custom normals, which both make it a no-go for me.

Thanks for your reply in any case. It’s good to hear that I’m not alone with my frustration.

Below is a link to an example scene that’s differently wrong from the ponytail on my character, but very wrong all the same. Maybe some physics pro can take a look at it and tell us how to set it up correctly?

OP: Have you tried playing with the Projection settings at all (for the joints in Phat)? It can tighten things up in cases like this. Haven’t tried it on ponytails myself, but similar situations, and it sometimes works well.

This seems to fix the separation of the joints at least. They are still behaving very strangely and wiggle all over the place, but maybe I can get it under control now by tweaking the dampening et cetera.

I’ll post an update later today once I got to play around with it some more. Thanks so far!

It seems I’m still missing one important step or setting. When there is little to no movement on my character, the physics look fine. But as soon as I start walking around, it’s just going crazy. Even if I set the dampening to astronomical values, it’s still jumping around every frame until I stop moving. It’s hard to tell from the .gif because of the low frame rate, but believe me… it ain’t pretty.

When I turn substepping off, it’s just twisting and turning the whole time. Which, I imagine, is not what should be happening either.

Maybe this cable plugin can help you.
https://www.vicogamestudio.com/development-blog/item/dynamic-rope-cable-system-for-ue4

It seems to work well (0:20)
https://www.youtube.com/watch?v=B31v7cNtF40

Hi Efrye,

I assume you are using the 4.8 release. We have actually fixed a few issues with skeletal mesh physics and world movement in 4.9 which I think will help you in this case.

There’s also a fix to PhysX which makes constraints projection work a lot better (this is also in the upcoming 4.9)

In general you should not have to use these damping values. If you’re able to do this, downloading the latest from github and compiling would help determine if there’s still some underlying problem.

Very good new! I have some problems with ponytail too…

Hey Ori,

You’re correct in assuming that I’m currently using 4.8. I’m not very familiar with compiling from github, but those 4.9 fixes sound great so I’ll definitely give it a shot and let you know how it turns out. Thanks!

Oh, and sorry for the late reply, I was on vacation for a few days. :smiley:

[QUOTE=Stane;334392]
Maybe this cable plugin can help you.
https://www.vicogamestudio.com/development-blog/item/dynamic-rope-cable-system-for-ue4

It seems to work well (0:20)https://youtube.com/watch?v=B31v7cNtF40[/QUOTE]

That’s looking really good indeed. I might consider it if 4.9 doesn’t fix it for me. Thanks for the links!

Building 4.9 took ages, but I finally got it to work (in no small part thanks to Zak Parrish). The physics look absolutely beautiful now!

I’m still having having problems with the collision though. The ponytail is swinging right through the body and arms in-game, even though it works in the physics editor. Does this require a special setup or is it a known issue as well? If so, can we hope for a fix in the final 4.9 release maybe?

Thanks a lot for this update in any case, it’s going to make my animations look much better! :smiley: