Physics objects clipping at high speed

Hi,

I have a ‘wall’ created from about 50 Shape_Cubes, set to simulate physics. They are set to movable, enable gravity, use CCD etc. They interact with each other perfectly, none of them clip through each other.

However, I am using an asset I made simply called Physics Ball. It’s just a Sphere, Static Mesh and ProjectileMovement componenet.

Root sphere is set to not simulate physics.
Static mesh one is set to simulate physics, and use CCD.
ProjectileMovement Velocity on the X axis is set to 1, with initial speed set to 2000.
All the 50 Shape_Cubes have CCD enabled too.

Yet for some reason the ball when fired clips through the cubes, it does collide with them enough to knock the wall over, but it doesn’t look right. Playing frame by frame makes it clear that the ball is pretty much flying through them, imparting enough force to push the wall of cubes over, but not make them fly everywhere.

Any ideas what I could be doing wrong, and how to resolve ?

Hi,

I’ve noticed a similar issues in [one of my questions]. In my experiments I’ve noticed objects smaller than 10 world units will sometimes clip through other objects. What is the size of your projectile ball in world units? (You can switch to an orthographic view and drag with the middle mouse button to measure it’s size with the ruler tool.)

I’ve noticed that in cases where precision is important, you can edit the physics settings in Edit > Project Settings. Turn on Substepping first. If you need more accuracy (which will be slower to simulate), reduce the Delta Time and increase the Max Substeps.

1 Like

Nice, but it’s worth noting this will not work on mobile.

you could fake your desired result by triggering a radial impulse actor attached to the physics sphere that fires an impulse at the hit location with a much larger force (explosive tip). have you tried your test using the first person template projectile?

Just an update that this will now work on mobile. It was added since