Download

Physics Constraint Component

Hi,

Im trying to set up a joint between two components in a construction script. But I can not get it to work. I’ve attached an image for how my blueprint is setup. I’ve tried settings Limits in separate functions also.

I don’t understand what is missing.

  1. Create a mesh
  2. Create another mesh
  3. Set one mesh to simulate physics.
  4. Add a constraintcomponent.
  5. Set the constrained components to the meshes I’ve just created.
  6. When I look in the scene the joint is clearly there. But when I press play they are not connected.

I’ve tried ALOT of different setups to get this to work. I’ve also tried writing the code in C++ with mixed bad results (I’ve sorta felt like I was getting close a couple of times).

Unreal Engine 4.6.1.

(I’ve also tried in 4.7)

Thanks alot,
Johan

I’m having the same problem.

I think there is a problem with the “set constrained components” node in some of the later engine versions. it was working in 4.3

https://answers.unrealengine.com/questions/160479/blueprint-set-constrained-components-failing.html

I had this same problem the other day. Try running the set constrained components on the BeginPlay event/function. This is what finally worked for me in C++ on 4.6.1

Hi lilb,

my blueprint creates 100’s of constraints in the construction script, I could store pairs of connections in an array I guess but it seems very heavy handed to me to need to run the set constrained components in the event graph.

The thing is I know 100% for sure that this used to work in previous editor versions. Thanks for the suggestion though, its a relief to know I’m not the only one who has hit this issue…

Super awesomeness, running it in Begin Play makes it work.

Thanks a alot!

I’ve attached how blueprint is setup now (and it works).

Basicly what Im gonna do in my real work is setting up a “SetConstrained”-class. And fill an array with those instead of calling “SetConstrainedComponents” and then loop through that array in the BeginPlay.

Best regards
:smiley: