Physics constraint component not destroying

When I try to destroy physics constraint component it still stays in place. Here’s a video

I kind of gave up with this… No-one seem to have answer.


I see that in your blueprint you are destroying your actor, and then destroying the component. Is there a reason for this? When you destroy the actor, it should also remove all of its components, so this should not be necessary. I do have a project where destroy component is working on a physics constraint, so I do know that it is functional, we will just have to find out why it is not working in your particular project. Have you tried to recreate a simple setup in a clean project and see if you are able to get the constraint component to destroy? I’d highly recommend doing so if you have not already.

Oh yea I might try that. The actor that I spawn is just the visual ball that has no logic inside it.

After you’ve seen if you can get it to work in a new project, I’d be interested to hear the results, and to see how you were setting it up. Let me know if you have any questions or run into any issues while trying to set it up in a clean project.

Hey Derzo, I recently encountered the exact same problem, and I found a solution that worked for me; the “Break Constraint” node did exactly what I needed.

Thanks, seems to be the answer!