Physics (collisions) and low FPS

Hi there,

So I have made a very simple pinball game, however the physics are completely messed up on low FPS devices. On my main workstation, I have 60+ FPS and all physics work perfectly fine, however if I enter t.maxFPS 20 in the console, the physics are no longer working correctly. Especially the collision detection (even though the “ball” has CCD (constant collision detection) enabled).

Any ideas?

This is the importance from set your FPS target, I afraid the only way to use Physics in your project properly is running at good FPS rate, anyway in your physics tab try to play with your Solver iteration times

Hope this helps

Thanks ZkarmaKun for your comment. I made two changes: 1) Enabled substepping (which seems to work on IOS 10.3.3, I no longer had weird physics issues). I’m not sure about the consequences regarding this so I will have to test further. 2) Disabled the 30 FPS cap on IOS.