Download

Physics / Collision Issue in Pinball

Hey Everyone,

Having a problem with the physics / collision in the Udemy Pinball tutorial. This DOES NOT occur in the Unreal Editor, but **DOES **occur after packaging the game.
http://imgur.com/a/Qosfy

During the tutorial he mentions raising the “Position Solver Iteration Count” and “Velocity Solver Iteration Count” to be higher numbers to resolve this issue. I’ve tried numbers as high as a 1,000 and that doesn’t help. I also have CCD enabled. I’ve tried multiple combinations of values, and enabling/disabling CCD, but nothing helps. Note I’m adjusting these values on the Ball Static Mesh component. I’ve even enabled CCD on the Pullback Lever and flippers, but still occurs.

Any thoughts on why this ball does what it does?

Thanks!

It looks like the flippers are moving far too fast, almost like they change in an instant. So when the ball is rolling down the flipper and you activate it, the new position of the flipper is above where the ball currently is?

I made a quick animation to show what I mean, so as the ball rolls so far down the flipper, when the flipper’s position snaps from its old position to its new one, the ball isn’t hitting anything, so it just falls.

Maybe I’m wrong, who knows. My best guess.

Flippers.gif

Hey man!

I’m sorry for my delayed response… I was not notified my post was approved and that you responded to it!!
Guess what though, you’re correct!

I had the flipper moving to that location in .02 seconds. I doubled to .04 and the problem has stopped. I went .05 to be safe!

Thank you so much!