Download

Physics chain glitching

I have made chain 1 month ago but it glitched, I make it shorter and the glitch was almost gone, today when I was going to try to make it better I realize it glitching even when it is shortened. I am desparated. 2 years ago when I made chain it just works and now with whatever settings it glitching. Do you have idea what can cause it, I set all elements to simulated, the mass scale to 1, 0.1 even 0.001 but nothing change. I set for the constraints “Projection linear tolerance” to 0 and now at least the elements not separating.

Wait for official .26
it works sooooo much better for these things than physx

Ok, but in the marketplace here are physics chain assets that work for 4.25. Isn’t here something that can be fixed? I don’t hope .26 to fix anything, some months ago I tried to make chain in .24 and it glitched in same way.

.26 uses completely different code, so unless you are the cause of the issue (which we can’t know given you haven’t shared a video of what the chain does) it will likely correct everything that is wrong with physx - and epic style, introduce a whole bunch of new issues :stuck_out_tongue_winking_eye:

So you tell me to wait 2 months and hope the problem to be solved with the new version? No thanks