Download

physics asset tool shows my wheels moving all over the place

https://answers.unrealengine.com/questions/259822/my-wheels-are-scrambling-in-physics-asset-tool.html

any help would be appreciated. I have been working on this issue for 3 weeks! cannot seem to get it to work.

ok sort out the orintation of the root bone X=forward Z=up , then you can set the wheels to kinematic

sometimes posting on the forum will get you more help than the answer hub

when you create your vehicle bp don’t add extra wheels to it, the wheeledvehicle code ONLY works with 4 wheels

Thanks Geodav, I rotated all of my bones to orientate the wheels correctly. Though the issue still persists In the physics asset tool the wheels scramble all over the place, they arenèt trying to get to the master bone, they just scramble everywhere, should I delete the centre bones?

here is the fbx attachment

Truck - Copy.blend - Google Drive is the blend file

please watch this video https://youtu.be/SZgBJld-KGg?list=PLXWXR2pLy_hV6UwhLjirhNnelWpOzGWRI
as mentioned in the above post your root/base bone MUST be aligned to the correct axis other wise the physics asset will not work , also the root bone MUST be at 0.0.0
when you export from blender make sure you “untick leaf bones” UE4 does not need them

please remember that the physics part of the engine the correct alignment of the bones

thanks geodav, its working now :slight_smile: but I still have the vert influence warnings, how do i get rid of that? I have all of my vertex groups assigned

most likely you have a very small triangle some where, not sure how you would find it in blender. could be a part that you thoght you have deleted but missed a tri

hey Geodav, it stopped working again. I followed your tutorial exactly but issues still happen.

Could you check the image in this post and tell me if something is going wrong, also I have placed the root bone at x:0, y:0 and z:0 in location but I still have problems