Physics Asset. Kinematic bones lag behind the simulated

I have a plane mesh with 2 animated wings. Wings slightly retract inwards and rotate when accelerating. I tried this both with the constraints and without but since I have to allow some linear motion cos the animation needs it this doesn’t seem to have any effect really, the wings are still lagging behind the rest of the mesh. I expected setting mode to kinematic would just have wings follow the rest of the plane perfectly but alas.
If I disable animations and add a constraint on the wings to root that completely locks linear movement the plane just starts spinning out.

Here’s what it looks like. Red line is the velocity vector. Wing on the left side is floating free, other is clipping inside:

Flying in a straight line, animations disabled - the 2 wing bones should be straight but they aren’t:

I use the set linear velocity to move the object/angular impulse to rotate if that’s relevant in blueprints. This is all one mesh, not attaching wings to sockets or anything.

Only 3 bones have any shapes added to them, here’s the setup.

How do I get them to follow perfectly?