Download

Physical Material with landscapes

I assigned physical materials to all my landscape layers and my blueprint always return “Default” surface type. Other materials (no landscapes) work fine and return correct surface type.

My blueprint looks like this:

What’s wrong?

I don’t know what happened but after restart Unreal Editor it works fine! … Bug?

Hello Kodmistrz,
what is this physical materials? Is this like a wind? I did not know what do you exactly mean with this Physical materials?
Kind regards,
Andreas

With physic materials you can add different e.g impact effects for different surfaces. Just as an example -> when you hit a wood surface the impact should be red and when you hit stone, it should be blue (both different materials should have a physic material assigned to them)

i can confirm this! Had the same problem, same node, same effect and solution.

Me too! Any solutions would be welcome.

Ta,

I had same problem Checking “Generate Overlap Events” solved it.

Thanks a bunch! This fix worked for me, though I cannot understand why it possibly would have anything to do with returning the correct physical material.

It must be tied in with “can receive hit”

That sounds plausible, but the hit actor was always correctly returned as the heightfield collision component for the landscape, even without checking the ‘can receive hit’ option. The only issue was that the physical material was always returning incorrectly. I’m under the impression that this may be a bug.

pulling up an old thread here - but a little more info:
sculpting a segment updates the physics material for that section
Checking and unchecking “generate overlap events” results in the new physics material working

From this, it seems that either action causes the collision to be updated, making this a bug, as the collision should be updated when changing physics material

Thank you!

With UE 4.24 I’m facing the same problem. Both with the previous generated ladscape and with a new one.
In this case no suggested solution resolved my issue. Anyone else?

I have the same issue in 4.24.1. Bevor 4.24 the solution above just worked fine for me. But I found a workaround by casting the hitactor to a landscape and getting the physical material from it. If someone finds a better way to fix this issue please let me know.

I’m having the same problem with 4.24.1, none of the solutions worked for me either except for casting to the landscape. Is this a known issue with this version?

It is, and there are a lot of recent reports. It’s nothing you can fix short of building the engine from the latest source.

Getting the same issue trying to do footsteps on a landscape under 4.24.1. Work around suggested by **BlackCryptix**doesn’t work for me either I get the “Default” return in that case as well.

Same thing… Waiting for solution and messing around with each thing which mouse cursor can reach to :slight_smile:

Nothing new?

Please, vote here: Unreal Engine Issues and Bug Tracker (UE-86165)