Physic Jitter


I am a newbie and I am sorry for this (hopefully simple) question.

I would like to simulate something like a few dominoes falling. I add a few scaled cubes, allow physics simulation and make them fall down. Regardless of linear (angular) damping values, their meshes physically overlap from time to time, with the gravity force they visually “merge” and when the other side of the overlapping mesh touches the one being overlapped, the entire overlapping mesh is pushed up and the process continues. That happens at the edges and generates jitter of the overall structure.


I have allowed sub-stepping, I played with mass, I created a physical material with friction=1. I created my own static mesh with more loops and added it as a complex collision mesh (as I do not know when the complex and when simple meshes are used to evaluate overlapping), I created 26 DOP simplified mesh - unfortunately nothing helps.

Can you please advise?
Thank you in advance.

Try to balance mass ratio of meshes. Nice tutorial is here UE4 Tutorial - Improve Physics Stability by Balancing Masses Unreal Engine 4 Tutorial - YouTube

GL :slight_smile:

Simple meshes are used to calculate physics and generally used deep in the engine. You can set complex meshes to be uses as simple… but this still can generate some troubles (always check if you have defined simple mesh for object)

Hi Jaco001,

Thank you for your response. I saw the video and already tried it. As recommended, all my boxes have 1:1 mass ratio, i.e. all of them have the same weight. Unfortunately - that did not help. I am sure that I am doing something incorrectly because it is a very basic scenario.

As long as I know, If I use complex mesh as simple, I can’t move it, i.e. it can’t serve as a collapsable domino block, is that correct?

Thank you.

It looks like you need to reduce min delta time in “Project settings” → “Physics” (no need to use complex or convex collisions).
(Also try to reduce min and max contact threshold).