Download

Phat - Third Person Template - Character falling through Floor

How do I put the settings right, so that I can use Phat for one bone and for the others it uses animations?

When I check Mesh–>Simulate Physics in the default settings of MyCharacter BP my pawn just falls through the floor in third person template. This happens on my custom character as well as on the default character coming with the template.

**Could somebody show me how to set up this third person template so that for the default character the head uses Phat physics simulation and the rest of the body is following the animation blueprint?
**
I followed all the tutorials on Phat, but I am unable to use Phat correctly for this puropose. And I tried many different variations in settings, but noone worked.

Thanks.

Edit:

The way I would like to do it is explained in this tutorial:

Like having an antenna on the top of the head where I have a bone skinned to. Then use animation for the character body movement and for the antenna I want to use spring constraints from phat.

Bump

I tried to make it work again today, but no luck:

  • I started with a new 3rd person blueprint template and default character. (or c++ template… … I tried both)
  • Added a physics asset to the character.
  • Activate physics for mesh in MyCharacte’s blueprint.
  • Alt - P and the character just falls trough the floor.

This is on 4.4.3

Guess I am not the first one having this problem:

Edit: When I check the floor mesh on the rolling ball template, it shows me the collision proxy in the editor (see picture below). When I check the floor in the 3rd person template it doesn’t have the collision proxy.

Then I exported the floor from the ball template and imported it in the 3rd person template, and the proxy disappeared as well. ???

723c634592ba98a28046802e2d2b5dc3cd14d782.jpeg

Edit2: Also importing the character to the ball template gives the same results… peeewwwww

I’m still learning, too. Have you tried creating a blocking volume for the floor mesh? If one’s not already there, select the floor in the Scene Outliner. Find “Create Blocking Volume” in the Details pane under “Static Mesh”. Open the drop-down menu and choose “Blocking Volume” for a simple volume.

First set everything back to default settings so that you don’t fall through the floor and who knows what other settings you turned off, it’s easy to break the game by changing the wrong setting.

In your physics asset select the collision object of the bone that you want to simulate and under physics type set it to simulated, this should be all that you need to do. If it still doesn’t work, go to the skeleton asset and in the bone tree on the left side of the screen, set the bones that you need to simulate from animation to skeleton.

Thanks for the answers, it works now. I thought I have to check use “physics for mesh” in the character blueprint for getting phat to work with character.

Do I have to use “physics for mesh” only when I want to use ragdoll behaviour? Or what is this option for?

My character still falls trough the floor when I check physics, even with the blocking volue mentioned. Eventually fiddleling with the collision setting might make this problem go away to.

Thanks again.

Well just a though.

Player physics wise it’s always in a state of falling and if the players collision overlaps a collision surface when spawning it will continue to clip through the surface. My guess since the collision is mid event it does not see the the trigger. It happens in other engines as well.

Old school trick is to spawn the player x number of feet off the ground and let it drop into the map.

Yes it’s used for ragdoll on skeletal meshes or rigid body physics, there is a collision preset called ragdoll specifically for this. When your character dies, you can access the collision settings in it’s blueprint and turn on physics simulation to make it a ragdoll.

Characters use the capsule component for their physics, make sure the capsule component has collision enabled and blocks all object channels, or you can set the preset to pawn.