Phat issues. Need help please


I have been struggling 6 days now with Phat for a character. This is holding up my project. And my frustrations are growing.

Basically all bones / bodies are being pushed apart severely.
My rig has all transforms set to freeze. Basically they have 0,0,0 translation information.

When i manually create the collision bodies on the physics asset the bodies behaves as if they are intersecting each other.
I have to either make them super small… which is not desirable… or just scratch any hopes of having a physics asset for my characters.

I have tried CAT rigs, normal bone rigs and basically exhausted all possible avenues. I have watched the Phat videos on the unreal youtube channel. Read all the documentation. My import of the animation work 100%. Leaving me to believe that Phat is broken. I am hoping i am wrong. But everything else works except phat.

Please. I beg you, the community and perhaps if a deity… throw me a bone. Help me out.
On the left the 2 legs have collisions enabled for each other. On the right the collision has been disabled for the 2 legs.

I would very much like to have limbs collide with each other.


Can someone please test the fbx file attached here

I need to know if my UE4 is corrupt or what is causing this. Please.

hi Crocopede,

I’ve downloaded your fbx and it looks like you’re scaling the root bone. Unfortunately this is not really supported by PhAT at the moment. We’re hoping to get full support for that by 4.6
I’ve also noticed that bone004 doesn’t have any vertices weighed to it.

Would you mind trying without the scale? The reason why the legs are pushing apart is that there’s a bug in the visualization of the body when bones are scaled. Under the hood the body is actually much larger. This visualization bug should be fixed in 4.5, though full bone scale support is still missing.

I’m sorry about the trouble I know it’s frustrating, please let me know if you run into any more issues


Thank you.
This pointed me in the right direction. Found that the system scale was set to inches. Causing the scale issue upon export.

Much appreciated for the help