Download

PHAT collision with CharacterMesh?

Hello! Sorry for the number of posts in the animation category the last few days, I’m finally starting to get somewhere and all the pieces are now finally falling into place.

I am trying to make a PhysicsAsset collide with my character’s skeletalmesh.
Originally it would collide with my character’s capsule component that’s used for general gameplay collisions, but I want this asset to be a lot more accurate as it’s attached to the character and shouldn’t interfere with movement and controls.
I made the PHAT a PhysicsBody object type with custom collisions settings and disabled pawn (which is the category the capsule component is set to) and enabled collision with CharacterMesh, which is the category the skeletal mesh is set to.
Yet the PHAT still just clips through the skeletalmesh of my character. Do you have any suggestions on how to move forward at this point?

I tried enabling per poly collision on both skeletal meshes just in case, but it didn’t solve the issue.

try and watch this diatribe on custom collision channels.
https://youtu.be/z0BGMRdQ3Dw

essentially i’m doing what you need.

Thanks! Finally Ii got it working.
There was a number of issues, first I hadn’t realised that “object type” and preset were two different things.
So I set the collision channels correctly according to types, but still couldn’t get it to collide with the character mesh.
But that turned out to be due to the collision of the mesh only being active during physics simulation, enabling per poly collision made it possible for the PHAT to interact with it otherwise.

I’m sure there’s a more efficient way and make use of the character’s PHATs collision primitives though.

The asset also jerks around quite often, but I think I can get rid of it with some tweaking of its settings.

You can try to increase the solver iteration to get something more stable - however - physics are unstable by design.
Shouldn’t be an issue for the lantern or grass, really…
It does become problematic when mixed with cloth at times though.

I think it’s just me expecting it to behave without enough leeway and it’s doing it’s best, I’ll add a few segments to the chain so it can move more freely.

https://www.youtube.com/watch?v=jq11OT_g7GA

Looks great considering.