Phat Bug Report 4.13

I think I found a bug in Phat, basically if you add to SK_Mannequin’s root a capsule and set physics blend between 1 and 0 you can’t grab (ctrl+RMB) the upper parts of the body (head,arms and torso) but only the calfs. If you remove it you can only interact with torso and sometimes with other parts of the body but usually the only responsive part of the body is the torso. In 4.12 I tried to do the same things and this doesn’t happen so I think this is a new feature (i would like to know the sense of it lol ) or just a bug.

EDIT: I installed 4.14 and this issue is still present

still no reply? I think this is a minor bug but stil a problem and it’s present in 4.15 preview too so nobody reported this yet

Hi Fiorenzone,

I attempted to reproduce this but couldn’t get your results.

What are the settings on the Capsule that you create (the popup menu)? Also, are you changing the size of that Capsule and overlapping any part of the Phat asset? Some screenshots of your setup would help.

Also, is this a separate issue from this report? Even if the repro isn’t exactly the same, I believe they are likely caused by the same issue.

https://answers.unrealengine.com/questions/553890/strange-ragdoll-issue.html

We haven’t heard back from you in a few days, so we are marking this post as resolved for tracking purposes. If you’re still experiencing this issue, please feel free to post back here with additional information to reopen the post.

Cheers,

TJ

hi,thanks for your replies,sorry If I’m answering only now but I completely forgot that on answerhub you can’t receive email notifications so I thought that nobody had answered me. Anyway I still have this problem and I can’t move my project from 4.12 to newer versions because in my project I use physics blend and I can’t interact anymore with ragdolls when they have their physics blend set < 1 and > 0, when I make a new project on 4.13 + the bug is there so I don’t think this is a capsule settings problem.It seems that in 4.13 the engine deal with physics in a new way, in 4.12 If I set my physics blend between 1 and 0 he react in a way, here instead I can move him around and I can even throw him away from the scene bounds.Maybe this in some way influence my issue.

Anyway sometimes I can’t reproduce this bug you have to try some times before seeing this to happen.

Difference between different engine’s PHAT
4.12:

4.13+:

Can you also get this to happen in a new project in 4.13+ or does it only happen in your project after it’s been converted?

Could you provide a test asset/project to help me reproduce this internally?

My problem is that I’m using trace line to check when I’m clicking on a npc to enable physics on him. This should happen even when their physics blend is between 1 and 0 (when they’re getting up) so that I can ragdolize them again while they’re standing up but I can’t upgrade this project to 4.13 because trace ignores some parts of the character when its physics blend is something like 0.5 so when they’re getting up there’s no way to check If I’m clicking on them. Here you can download a little test I made to show you this problem. Press E to set physics blend of the mannequin to 0.5 then with LMB you can see that the line trace ignores the legs and other parts of the mannequin’s body.

LINK 4.13 :Google Drive: Sign-in

Thanks for the test project. I was able to reproduce the issue and I’ve created JIRA UE-41821. Our developers will be investigating further. Follow that link to monitor the status of the bug report.

Cheers,

TJ