Download

Perspective Camera problem

Hello, I’m using the perspective camera in my 2.5D Platformer so that I have depth in my levels. However when I put an object on the foreground, as in, in front of the player on the X axis, the camera will change when I walk past it. Zooming in on the player. How is it possible to disable the perspective view change?

There is a camera setting that enables/disables collision. Check the camera in the components panel and take a look for that setting.

Unfortunately there is no such option. Any other ideas?

Hello,
As Chumble said, if your camera is in a blueprint, you’ll find it in component tab in camera boom component : Camera collision.
If you have only a camera, in your blueprint or in level blueprint if you don’t have blueprint, set a reference in event graph and drag a "set actor enable collision " from it.

It worked, thanks!