Download

Perplexing day-night lighting issue with material (4.26.1)

I am encountering a strange problem when trying to create what should be a very simple day-night cycle.
Using the level blueprint to rotate a directional light and then updating the sun direction seems simple enough.

However I am seeing some strange behaviour.
[HR][/HR]
1.This is my island, weight-blended material with LayerInfo and all that jazz sorted.

[HR][/HR]
2. This directional light is meant to be for the sun. It is the only light in the scene, yet see how the scene is not reacting correctly to the light angle. Why is the beach illuminated?

[HR][/HR]
3. Approaching down 45 degrees, I finally get something like I would expect for the rest of the day, but the moment is fleeting.
[HR][/HR]
4. At the time when everything should be most dazzling, I get this? That ground isn’t shaded by something - the material turns black.
[HR][/HR]These materials are not funky in any way, they are bog standard materials with no strange settings beyond the need for layer info. At first I thought the light was not rotating properly with the sun but it definitely is. At 4pm every day, I can see my level but I’m stuffed the rest of the time.

There is no static lighting in the scene.
The directional light has bAffectsWorld=true
The directional light has sufficient intensity (1.8 - 24 Lux tested)
Volumetric Lighting and Dynamic Shadows enabled.
Choosing double-sided shadow didn’t help.
Moving it by gimble in the editor or having it attached to the sun produces the same result.
I’ve done this before in a project and have copied the objects, checkboxes and code exactly - triple checked, deleted, remade and the same thing happens. I even tried using an event tick instead of my favoured TimeLine to rotate the light in case I borked something there; same results. The fact it looks correct at one time of the day is very confusing.
[HR][/HR]5. For completeness, here’s the map material (weight not height used - I painted it on myself)

I keep thinking to myself there is a checkbox somewhere or an inverted channel or something that I have changed by mistake, but for all my experience, I’m stumped.

I am not very familiar with this forum and I *think *I may have posted this in the wrong place. My apologies.

I’ve fixed it myself.
In the blended material, the blend node for the normals must have the same item names as the blend node for the diffuse textures, so that it applies the normals to the textures already in the other node. Facepalm