Permission requiired you must approve this premission in app settings:storage

When i package my android game to distribution and try and open it i get the message permission requiired you must approve this premission in app settings:storage does anyone know how to fix this because i want to publish my game but i cant because no one will be able to get past this screen on launch

2 Likes

I’m getting the same thing. I’m trying a small, simple test app to package to android. It doesn’t require saving files, but still prompts for permission to storage. But when I click ‘Settings’, the permissions option shows ‘No request’ .

Were you able to find a fix?


4 Likes

I have the same issue

1 Like

Dragoneel,

I found that I was installing the project to my phone the wrong way. I was copying the APK to my phone and tapping the file to install. This had worked in an earlier version of UE with a previous project. I guess UE5 and my project setup wouldn’t install this way.

Instead, I had to use the ADB setup, and run the “Install{ProjectName}.bat” that was placed in the packaging directory after Packaging the project.

Setting Up Your Android Device for Developing Applications in Unreal Engine | Unreal Engine 5.1 Documentation

Packaging Android Projects in Unreal Engine | Unreal Engine 5.1 Documentation

1 Like

Hi @LocoLeppy LocoLeppy, did you find a solution to this problem? I’m also stuck with this problem, trying to distribute the App via PlayStore for internal testing.

i found the issue ticket here and it’s marked as fixed,
unfortunately, I built unreal from the source on the fix commit, but it’s still not fixed.

cuz script is simply grantingthe permission throug the adb.

@echo Grant READ_EXTERNAL_STORAGE and WRITE_EXTERNAL_STORAGE to the apk for reading OBB file or game file in external storage.
%ADB% %DEVICE% shell pm grant com.YourCompany.mansayrb7almillion android.permission.READ_EXTERNAL_STORAGE
%ADB% %DEVICE% shell pm grant com.YourCompany.mansayrb7almillion android.permission.WRITE_EXTERNAL_STORAGE

however for distrubtion that won’t work

1 Like

Have any of you guys had any luck with this at all, I’m encountering the same exact issue and have attempted the following.

Adding the following permissions:
android.permission.WRITE_EXTERNAL_STORAGE
android.permission.READ_EXTERNAL_STORAGE
android.permission.WRITE_INTERNAL_STORAGE
android.permission.READ_INTERNAL_STORAGE

Enabling the following toggles:
UseExternalFilesDir for UnrealGame files
Disable verify for OBB on first start/update

Even with these settings enabled and setup in my project settings I am still unable to play test my project on my android device as it pops up informing me that there are no permissions available

Failure [INSTALL_FAILED_USER_RESTRICTED: Invalid apk]

There was an error installing the game or the obb file. Look above for more info.

I get this error message. Any solution or idea how to fix this error?

I can only run the install_xxx.bat command to install APK. Because ‘.bat’ also enables storage permission after the installation is complete by ‘grant xxx.xxx.xxx android.permission.READ_EXTERNAL_STORAGE’

Pardon the necro, but has anyone actually resolved this issue? I’ve found multiple threads on this issue (between these forums and reddit) going back multiple years with no definitive resolution in any of them. Given the multiple years, it seems like this might be a regression issue, as in they fix the problem in one version of UE then break it again in another.

For my own part, I’m able to make working standalone APKs with UE 5.0 (tested with multiple projects), but am unable to make working standalone APKs with UE 5.1 (also tested with multiple projects, all of which indicate this lack of storage permission issue). I’ve also tried the potential fixes noted by Lou781 up above with the same lack of success (I also confirmed these changes in the editor settings are replicated to the Android manifest).

Is there some secret sauce that those in the know aren’t sharing?

Hello! did you manage to solve this problem?

I didn’t. I submitted a bug report and I am waiting for Epic to review the ticket. I’ll post a link to the ticket if they accept it.

1 Like

I was able to do it.
So:
Install Android Studio as in this video Unreal Engine 5.1 🎉Full Setup🔥 Latest SDK NDK JDK For Android Mobile Game😍 Export Complete Guide 🔥 - YouTube

jdk download here
Liberica Standard JDK 8u302+8 x86 64 for Windows

Well, screenshots of how I have it set up

Please note that I have JavaHOME version 802, it’s legacy, I didn’t change it.

It doesn’t seem to be in Android Studio.
I’m all scrapped when I ticked Show Launch Image
Just uncheck it and everything will work…

5 Likes

This solution at least let me enter the app, where I’m specifically requesting for other permissions.

1 Like

Okay, so interestingly. The fix for me was just unchecking “Show launch image”. I tested this with two projects (a working project and a clean template) and two phones (S20 and Note20). I can confirm this resolved the issue in each case. Kudos to Fe_Games_Studio for pointing that out.

I left everything else as indicated in the 5.1 documentation.

Setting up Android SDK and NDK

Android SDK Requirements

This is fine for my purposes for the time being, but I have to imagine folks will want/need that launch image when they go to make release builds. Hopefully Epic will accept my bug report so I can add this finding to it so they can get the underlying issue resolved.

2 Likes

edit bat file, add “-g” after “install” and before project name (single spaces)

(For testing incase bat file doesn’t work too)

Same issue, bug , when launch image is off works but when is on Error Storage permission.
I need launch image because of PSO loading waiting.

I also got these same problem but this is how I fix it.
This type of storage permission are not supported by Android 13 that is api33 ,try to lower the API to 32 this lowering the API to 32 will fix this problem.for me it works .