Download

Permanently set time of day

Hi!

I have downloaded UE off and on and played around a bit but have never been able to permanently set the time of day.

Rotating the sun around by deleting the Directional Lamp does, just that and rotating the lamp doesn’t seem to do much.

I have seen the Time of Day tutorial but I don’t want the sun to run around, I would like it to stay at a fixed position through out the game. I am sure this is a really stupid question and I apologize for it but I would appreciate any help I can get.

Thanks

Select the directional light, which is the sun, then rotate it to the height you want and leave it like that. It wont continue to rotate in game by itself.

How do I make it night, permanently? I see that in the Time of Day tutorial, I have to set the “Light Source” but I can’t find it in Blue Print or in the properties.

Thanks

Just do what Jacky suggested ^^ -> but make sure to build the light after you have moved it + disable “colors determined by sun” in the sky blueprint. Or when you want the map to be completely dark, just start a blank template map

Ok, so I have tried this with a blank template (which btw has the sun in the sky; a blue sky). After I rotate the directional light (Z-Axis to -74) and Build Lights. The sun doesn’t move.

This is too complicated. Is the light connected to the Sun or do I have to Blueprint the connection and do something fancy to hide the sun to set it to night?

When I set the Sun to a negative value, stars come out but the sunlight is still there. I feel like I am missing something here. There is more to it than just rotating the light and the sun.

Thanks

Delete the sky sphere, set the sun’s rotation, reduce it’s intensity to 0, build the lights and you’ll get night time.

  1. rotate the sun
  2. build the light
  3. click onto the sky bp and then make those changes:

0d03aaf01add21f6a14b9cc80f2ef4cdbb6e8a67.jpeg

  1. set the directional light intensity to 0
  2. set the environment colour in the world settings to black

EDIT: Lol ok ignore this post the suggestions above are way easier. . .

So, this is a pretty hacky workaround I’ve been using for a project. It involves you having downloaded/some basic understanding of the Time of Day template/tutorial (which I’m guessing you’re referring to).

  1. Use the time of day blueprints/template for your level
  2. Set the time of day you want under “Default Hour” - (you’ll see this update dynamically in the editor - if you want night time, it’ll be a later hour, obviously).
  3. Set time speed to 0 - (so there is no movement of the sun/light)
  4. If you are using a purely daytime level, I usually “hide moon during the day”

If you are trying to set this up with a blank template and you’ve been working with the imported BP Skysphere from the Time of Day tutorial linked above, you’ll need to make sure you delete the existing Skysphere from the default template. I’m wondering if that may be the issue with the project describing above.

Hope this helps! (and, again, very hacky - sure there are easier ways of doing this).

I deleted the sky sphere (which removed clouds and stars as well, I wanted those to stay there like in the Time of day tutorial) and the sun is still in the sky. Rotating the directional light around has no effect. At one point it became dark when I set the Z-Axis to -360 or something like that but I have not been able to do it twice with any combination of values.

Building the Lights didn’t produce any major change, except the shadows moved in direction.

How do I move the sun? Without the sky sphere I don’t know where the controls for the Sun (or the white glowing disc in the sky) are.

Thanks

You are probably rotating it in the wrong axis. Rotating around X should move it below the horizon. And if you want stars at night follow fighter’s suggestion, that’s as easy as it gets.

Select the directional light in the scene outliner and rotate it -> then follow my steps

rotate.jpg

Ok, I was able make it dark without the sky sphere by rotating the light on the Y-Axis and the sun moved with it. I created a new project with the sky sphere and did the same but the sun doesn’t move. Is there any way to tie the sun to the light when the sky sphere is present?

Thanks

In the sky blueprint properties you can add your light

Thank you T35513R, for running a quick remote session and walking me through this!

Here are the steps to creating a perfect night scene:

  1. Rotate the Directional Light so it is pointing up.
  2. Uncheck “Colors Determined” (very important, this is what was causing the red haze on the horizon) in the Sky Sphere properties
  3. Set Sun brightness to 0 in the Sky Sphere properties
  4. Set Star brightness to more than 0 (setting it to 75 will make them appear instantly) in the Sky Sphere properties
  5. Set Zenith, Horizon, Cloud and Overall colors in the Sky Sphere to your liking.

Please also note, Unreal Engine simulates real vision and it take about 15 seconds before the stars actually fade into view. Also, Build the scene to correct shadows.

Epic needs to write a book on Lightmass, there is a lot of detail here and no documentation for it (or at least I couldn’t find it).

Thank you all for your time and help. I hope this will be useful to others.

This time of the day isnt really working?
I want to make the terrain goes dark at night but it still behave as it’s illuminated by the sun. Even before rebuild.
What can be wrong.
Ill post pics later.

Hi Klaus,

You need to make sure that when you’re Sun is below the landscape that you’re turning it’s brightness down to 0 otherwise you will receive light from below.

Take a look at this AnswerHub post for tips on setting this up in the level blueprint.

I hope this helps!

Tim

As you can see set to 0 the brightness and rebuild the scene, nothing changed, still looks like illuminated, also the sun position is below.
I even put a hollow cube, got inside and what should be a total black still is illuminated, even on the corners, thats wierd.

Can you help me?
I just want the cicle to work and the night feels like the night.

You’ll also need to go into the World Settings and change the environment color to reflect in your scene as Fighter pointed out above in this post: https://forums.unrealengine.com/showthread.php?27735-Permanently-set-time-of-day&p=114065&viewfull=1#post114065

thanks Tim, that worked.

So now the terrains is dark, but the upper park of the foliage (trees) is still lit. the brench is dark. Thats odd. Any ideias why is that?

Do you mind posting a screenshot?

Thanks!

Tim