Download

Performance Questuion

Hi all,

I have a packaged project and it plays great on my GTX 970. I have three other machines one has a 660Ti, GTX 760 and a GTX 960. The playback on those machines gets pretty choppy. How should I package my project so that it will play smoothly on various machines? Not all of my clients will have a GTX 970. Is there a way to go about this?

Thanks for advice.

Aaron

The way I see it, the problem is not in the project packaging process.

Have you define the minimum machine spec for your projects? If you have, you need to test your projects in that machine extensively and almost exclusively. Content optimization must be done for that minimum spec machine (i.e. employs LOD for 3D objects, low polys for unimportant 3D objects, etc.). And don’t forget to set the minimum FPS required for that minimum machine spec.

After you are happy with the result, tell your clients the minimum spec and recommended spec machine so they don’t get the wrong impressions about your work.

Easy! Had the same problems. What you need is a graphics settings section in your scene and have the whole program boot up with low graphics.

Tonight, I’ll upload a tutorial with images here on this post!

Interested in seeing the tutorial. Thanks

Started it last night but it got lengthy. I think I’ll just post the screen shots of my blueprints.

Is this similar to when playing a video game were you can go into options and change performance and resolution settings? No rush. I am no where near ready for client distribution.

Thanks for your help!!!

Are you still able to show us your blueprints and how they work?

Thanks,

Aaron

Here is how I did it. Simply create a pause menu and in that pause menu, create 4 buttons. Name them something like Ultra, High, Medium, and Low. Then look a the pictures and follow what I did.

a98f6b6f4e99e0876b8775115e0bc8427ffafdce.jpeg
58bef5e4e59149a091d5cc0982cd326a2d86bad8.jpeg
Graphics 2.jpg

Thanks for posting. Would you be willing to drop box a scene with this merged into it? I can not read the text. To small.

Right click the images, save as, or open in new tab to zoom in :wink:

Right click the images and select open in new tab. You’ll see it at full resolution.